This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 375001 - Dimension 5150 with 2 SATA drives and IDE DVD won't boot Fedora 7 or 8 DVD
Dimension 5150 with 2 SATA drives and IDE DVD won't boot Fedora 7 or 8 DVD
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-10 14:18 EST by Joseph A. Farmer
Modified: 2008-05-21 23:57 EDT (History)
3 users (show)

See Also:
Fixed In Version: 9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 23:57:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Camera pictures of screen in ready state. (34.61 KB, image/jpeg)
2007-11-10 14:19 EST, Joseph A. Farmer
no flags Details
dmesg of machine running FC6 (20.58 KB, application/octet-stream)
2007-11-10 14:23 EST, Joseph A. Farmer
no flags Details

  None (edit)
Description Joseph A. Farmer 2007-11-10 14:18:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.12) Gecko/20070718 Fedora/1.5.0.12-4.fc6 Firefox/1.5.0.12

Description of problem:
Machine is a Dell Dimension 5150.   The machine has 2 SATA hard disks and 1 IDE DVD.  It runs FC6 fine but attempting to boot either Fedora 7 or 8 DVDs results in failure.  The machine initially boots the DVD but after loading vmlinuz and initrd.img a "Ready" appears on the screen and the machine hangs there.  Waiting for 15 minutes with that Ready on screen shows it's stopped there.

Attached are an image the screen in hung state and a copy of the dmesg from the machine with FC6 running.



Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1.  Insert Fedora 7 or 8 DVD
2.  Power on
3.  Machine starts boot and then stops at the Ready text.

Actual Results:
Machine hung there.

Expected Results:
Should have moved on to the next screen of the install process.

Additional info:
Again, FC6 boots and runs.  Fedora 7 and 8 won't make it past booting the DVD.
Comment 1 Joseph A. Farmer 2007-11-10 14:19:22 EST
Created attachment 254091 [details]
Camera pictures of screen in ready state.
Comment 2 Joseph A. Farmer 2007-11-10 14:23:08 EST
Created attachment 254101 [details]
dmesg of machine running FC6

Machine runs fine with FC6.  To install on this machine I think I installed a
CD-ROM drive with no write ability as FC6 would start installing and then not
be able to find the CDROM or DVD part way through install.  It did that on 3
machines so I ran a series of drives through it and found a simple CDROM ready
worked but the DVD drives and CDRW drives would fail.  I think that was unique
to FC6 as FC5 didn't have the same problem on any of the machines.  Known bug I
think.

This bug is different in that another machine boots the DVDs for Fedora 7 and 8
fine but that is a different model machine with PATA hard disks.
Comment 3 Joseph A. Farmer 2007-11-12 02:09:25 EST
Ok, I have a workaround which doesn't fix the problem but does what I was after.
 I took the Fedora 8 DVD to another machine and made a bootable USB thumbdrive
with that bootimage file in the images folder (using DD).  Then I set the bios
of the Dimension to boot the USB stick.  Once it was booted I inserted the DVD.
 The only trick (found the hard way) was to change the grub configuration as it
defaulted to the USB stick being the first drive.  That wiped out the stick the
on the first install and left an unbootable Dimension.  Changing SDA to be the
first disk allowed an install and the machine is currently running Fedora 8 (I'm
on it now).

The machine still won't boot the DVD so I can test that.  
Comment 4 Christopher Brown 2008-02-07 12:39:32 EST
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the Fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Are you able to test
with an updated spin from the fedora unity project?

http://spins.fedoraunity.org/spins

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.
Comment 5 Joseph A. Farmer 2008-02-10 23:55:12 EST
"or I'll do so in a few days if there is no additional information lodged."

Closing bugs, which are still open, is more important than actually fixing them
then?  Go ahead and close it, knock yourself out.  I can work around the problem.

No.  I will not download a FedoraUnity Spin.  I tried that once and it was a
disaster.  They use some file format I don't have and really don't care to get into.

Fedora 9 was released into alpha last week.  It'll soon be released into
production.  When that is released I'll download the DVD.  At that point the
machine will either boot or it will not.  If it does not, and this bug is
closed, I'll upgrade via YUM and simply ignore it.  Hidden bugs, which are
worked around, will not show as open bugs so sweeping it under the carpet will
work nicely if that's the intent.

Yes, I have a bad attitude.  The last bug I filed was received by a fresh
graduate of the Vogon school of computer science.  This makes two.

Many eyes may find many bugs but if those eyes no longer report the bugs they'll
breed.  That's fine - I can find workarounds.
Comment 6 Christopher Brown 2008-02-11 08:00:58 EST
Hi Joseph,

I didn't explain my actions well enough perhaps. With installer bugs we
essentially have two options:

1) Test a fedora unity spin - these are released and resolve issues with the
original installer which were missed in QA. I coped two people into this bug who
work on installer issues or for the unity project and they may comment should
they wish to.

2) Ask the reporter to test with a test release of the next version of Fedora.
In this manner if the bug is still an issue then the reporter can work with the
kernel and installer team to make sure it is not present in the release version.
That is the option it sounds like you are planning to take.

It is certainly not the intent of the triage team to just close bugs to lower
the bug count. As the next phase of development begins we are working to
identify as many issue as possible so that the next release works for more
people on more hardware and is generally of better quality.

I'm not sure what you mean by:

"The last bug I filed was received by a fresh graduate of the Vogon school of
computer science"

but if you had issues with another bug please email me privately and I will
happily investigate.

Please update this bug with your Fedora 9 experiences and we can hopefully get
this problem resolved prior to F9 Release.

Regards
Chris
Comment 7 Jeroen van Meeuwen 2008-02-11 09:52:55 EST
Hello Joseph,

the Fedora Unity Re-Spins are released via torrent also, maybe that is a better
format for you to handle:

http://spins.fedoraunity.org/unity/torrent-files-fedora-8-20080204

As it is built upon a newer kernel, this might solve your problem, and I'd love
to hear if it actually does.
Comment 8 Joseph A. Farmer 2008-02-16 20:56:44 EST
Problem still exists with Fedora 9.

I downloaded the Fedora 9 DVD.  Same result.  Machine boots to the first screen
and when I select "Install" or "Upgrade" a new screen replaces that.  vmlinuz
and initrd and then the word "ready." with the period.  That's it.  No more
activity after that.

The DVD is the alpha.  It contains a media.repo file with:
[InstallMedia]
name=Fedora 9-Alpha
mediaid=1201644547.220556
metadata_expire=-1
gpgcheck=0
cost=500

I don't know what version of the kernel is on that DVD.  In the packages
directory is kernel-2.6.24.2.fc9.i686.rpm so that's likely it.



Comment 9 Christopher Brown 2008-02-17 12:17:36 EST
Add the option

edd=skipmbr

and it should install for you.
Comment 10 Chuck Ebbert 2008-02-29 18:58:05 EST
Joseph, did edd=skipmbr work?
Comment 11 Joseph A. Farmer 2008-05-21 23:57:18 EDT
Fedora 9 fixes the problem.  If I understand bugzilla correctly I just closed
it.  If not somebody can close this as fixed.

Note You need to log in before you can comment on or make changes to this bug.