Bug 375021 - Desktop machine fails to resume from hibernation: regression from F-7
Desktop machine fails to resume from hibernation: regression from F-7
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-10 15:42 EST by Alex Lancaster
Modified: 2008-10-16 19:35 EDT (History)
3 users (show)

See Also:
Fixed In Version: 2.6.27-3.fc10.i686
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-16 19:35:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of /sbin/lspci -v (2.97 KB, text/plain)
2007-11-10 19:54 EST, Alex Lancaster
no flags Details
/sbin/lscpi -v output (3.15 KB, text/plain)
2007-11-10 19:57 EST, Alex Lancaster
no flags Details
output of /usr/sbin/dmidecode (13.68 KB, text/plain)
2008-02-16 03:38 EST, Alex Lancaster
no flags Details

  None (edit)
Description Alex Lancaster 2007-11-10 15:42:12 EST
Description of problem:
Upgraded my desktop from F-7 to F-8.  The machine, a Pentium III, now fails to
hibernate, this worked on the last kernel shipped for F-7.  Complains about ACPI
errors

Version-Release number of selected component (if applicable): kernel-2.6.23.1-49.fc8

How reproducible:
Always

Steps to Reproduce:
1. "System"->"Shut Down"
2. Choose "Hibernate"
  
Actual results:
After a second or so the screen goes black, and I can see a VT with a cursor
blinking, after another second or so, the screen goes back to X11 mode with lock
dialog appearing after moving the mouse.

Kernel output in /var/log/messages:

Nov 10 03:13:10 binoche ntpd[1755]: ntpd exiting on signal 15
Nov 10 03:13:13 binoche restorecond: Read error (Interrupted system call)
Nov 10 03:13:13 binoche kernel: swsusp: Marking nosave pages: 000000000009f000 -
0000000000100000
Nov 10 03:13:13 binoche kernel: swsusp: Basic memory bitmaps created
Nov 10 03:13:13 binoche kernel: Stopping tasks ... done.
Nov 10 03:13:13 binoche kernel: Shrinking memory...  #010-#010\#010done (8520
pages freed)
Nov 10 03:13:13 binoche kernel: Freed 34080 kbytes in 0.35 seconds (97.37 MB/s)
Nov 10 03:13:13 binoche kernel: Suspending console(s)
Nov 10 03:13:13 binoche kernel: sd 0:0:0:0: [sda] Synchronizing SCSI cache
Nov 10 03:13:13 binoche kernel: pnp: Device 00:0b disabled.
Nov 10 03:13:13 binoche kernel: pnp: Device 00:0a disabled.
Nov 10 03:13:13 binoche kernel: pnp: Device 00:09 disabled.
Nov 10 03:13:13 binoche kernel: ACPI: PCI interrupt for device 0000:00:0d.0 disabled
Nov 10 03:13:13 binoche kernel: Trying to free already-free IRQ 9
Nov 10 03:13:13 binoche kernel: ACPI: PCI interrupt for device 0000:00:0b.0 disabled
Nov 10 03:13:13 binoche kernel: ACPI: PCI interrupt for device 0000:00:0a.0 disabled
Nov 10 03:13:13 binoche kernel: ACPI: PCI interrupt for device 0000:00:04.2 disabled
Nov 10 03:13:13 binoche kernel: ACPI Exception (exoparg2-0442):
AE_AML_PACKAGE_LIMIT, Index (00000000C) is beyond end of object [20070126]
Nov 10 03:13:13 binoche kernel: ACPI Error (psparse-0537): Method
parse/execution failed [\_SB_.PCI0.IDE0.CHN0._GTM] (Node f7c6a918),
AE_AML_PACKAGE_LIMIT
Nov 10 03:13:13 binoche kernel: ata1: ACPI get timing mode failed (AE 0x300d)
Nov 10 03:13:13 binoche kernel: pci_device_suspend():
ata_pci_device_suspend+0x0/0x27 [libata]() returns -22
Nov 10 03:13:13 binoche kernel: suspend_device(): pci_device_suspend+0x0/0x47()
returns -22
Nov 10 03:13:13 binoche kernel: Could not suspend device 0000:00:04.1: error -22
Nov 10 03:13:13 binoche kernel: ACPI: PCI Interrupt 0000:00:04.2[D] -> Link
[LNKD] -> GSI 9 (level, low) -> IRQ 9
Nov 10 03:13:13 binoche kernel: ACPI: PCI Interrupt 0000:00:0a.0[A] -> Link
[LNKC] -> GSI 5 (level, low) -> IRQ 5
Nov 10 03:13:13 binoche kernel: PCI: Enabling device 0000:00:0b.0 (0000 -> 0002)
Nov 10 03:13:13 binoche kernel: ACPI: PCI Interrupt 0000:00:0b.0[A] -> Link
[LNKB] -> GSI 10 (level, low) -> IRQ 10
Nov 10 03:13:13 binoche kernel: ACPI: PCI Interrupt 0000:01:00.0[A] -> Link
[LNKA] -> GSI 11 (level, low) -> IRQ 11
Nov 10 03:13:13 binoche kernel: pnp: Device 00:09 activated.
Nov 10 03:13:13 binoche kernel: pnp: Device 00:0a activated.
Nov 10 03:13:13 binoche kernel: pnp: Device 00:0b activated.
Nov 10 03:13:13 binoche kernel: sd 0:0:0:0: [sda] Starting disk
Nov 10 03:13:13 binoche kernel: Restarting tasks ... done.
Nov 10 03:13:13 binoche kernel: swsusp: Basic memory bitmaps freed
Nov 10 03:13:14 binoche NetworkManager: <info>  Waking up from sleep.

Expected results:
Should hibernate to disk.

Additional info:
This worked just fine in F-7, after step 2, it would switch to a virtual
terminal and I would see a percentage indicator as it saved state to disk, then
it shutdown and resumed fine.
Comment 1 Alex Lancaster 2007-11-10 19:54:23 EST
Created attachment 254151 [details]
Output of /sbin/lspci -v 

Added hardware information: output of /sbin/lspci -v
Comment 2 Alex Lancaster 2007-11-10 19:57:29 EST
Created attachment 254161 [details]
/sbin/lscpi -v output

Run as root this time.
Comment 3 Till Maas 2008-01-13 11:15:02 EST
Did you try this with the latest kernel (2.6.23.9-85.fc8)? I have a Pentium III
here, too, and I just found out, that it hibernates and suspends without major
problems.
Comment 4 Alex Lancaster 2008-01-27 10:08:00 EST
(In reply to comment #3)
> Did you try this with the latest kernel (2.6.23.9-85.fc8)? I have a Pentium III
> here, too, and I just found out, that it hibernates and suspends without major
> problems.

Just tried hibernating with kernel-2.6.23.9-85.fc8, no dice.  Still get same
problem with the ACPI timing mode problem.. :-(

an 27 08:03:12 binoche kernel: ACPI Exception (exoparg2-0442): AE_AML_PACKAGE_L
IMIT, Index (00000000C) is beyond end of object [20070126]
Jan 27 08:03:12 binoche kernel: ACPI Error (psparse-0537): Method parse/executio
n failed [\_SB_.PCI0.IDE0.CHN0._GTM] (Node f7c67918), AE_AML_PACKAGE_LIMIT
Jan 27 08:03:12 binoche kernel: ata1: ACPI get timing mode failed (AE 0x300d)
Jan 27 08:03:12 binoche kernel: pci_device_suspend():
ata_pci_device_suspend+0x0/0x27 [libata]() returns -22
Jan 27 08:03:12 binoche kernel: suspend_device(): pci_device_suspend+0x0/0x47()
returns -22
Comment 5 Chuck Ebbert 2008-01-28 20:26:28 EST
libata ACPI is enabled in the Fedora 8 kernel and is the source of the errors.
It can be disabled with by adding this line to /etc/modprobe.conf:

options libata noacpi=1

Then the initrd must be rebuilt, or the kernel reinstalled.
Comment 6 Alex Lancaster 2008-01-30 06:40:59 EST
(In reply to comment #5)
> libata ACPI is enabled in the Fedora 8 kernel and is the source of the errors.
> It can be disabled with by adding this line to /etc/modprobe.conf:
> 
> options libata noacpi=1
> 
> Then the initrd must be rebuilt, or the kernel reinstalled.

That worked for me!  Thanks!  Before I close the bug, is there any way this can
be automated or otherwise fixed so that this problem doesn't bite newbies?  Was
there a reason to disable libata ACPI?   Can it be re-enabled or selectively
enabled on certain hardware?

I suspect that there will be other users of Fedora using older hardware who are
likely to encounter this bug and it seems that there should at least be a
warning or pointer generated by the hibernate script if the hibernate fails with
instructions on how to work around this issue.
Comment 7 Christopher Brown 2008-02-07 12:51:25 EST
I'll assign this to Alan for comments on whether your hardware can be
blacklisted. If you can attach output of:

# lspci -vvxxx > lspci_verbose.out
# dmidecode > dmidecode.out
dmesg > dmesg.out

as text/plain attachments that might help.
Comment 8 Alan Cox 2008-02-07 15:43:26 EST
No plan to blacklist it - that isn't an IDE problem really but either a broken
BIOS or us invoking methods on the ACPI side wrong. Probably best to report it
to the ACPI folks for opinions.

2.6.24 is a bit more forgiving about IDE ACPI errors because yours isnt the only
box that turns out to have "interesting" behaviour.
Comment 9 Christopher Brown 2008-02-07 19:36:25 EST
Okay, thanks. Alex - can you see if a later BIOS is available. The output of:

# dmidecode

will be more informative on this.
Comment 10 Alex Lancaster 2008-02-16 03:38:38 EST
Created attachment 295064 [details]
output of /usr/sbin/dmidecode

Attaching dmidecode output as requested.  I'll have a look to see if there's a
newer BIOS for this motherboard, there most likely is.
Comment 11 Alex Lancaster 2008-06-15 09:57:54 EDT
Yet another regression on F-9 with kernel-2.6.25.6-55.fc9.i686

Now I it does not resume from hibernation at all.  This is on the same hardware
with the /etc/modprobe.conf workaround mentioned in comment #5.

Here's what I see in /var/log/messages as it is sleeping:

Jun 15 06:28:44 binoche NetworkManager: <info>  Sleeping...
Jun 15 06:28:44 binoche NetworkManager: <info>  (eth0): now unmanaged
Jun 15 06:28:44 binoche NetworkManager: <info>  (eth0): device state change: 2 -> 1
Jun 15 06:28:44 binoche NetworkManager: <info>  (eth0): cleaning up...
Jun 15 06:28:44 binoche NetworkManager: <info>  (eth0): taking down device.
Jun 15 06:28:44 binoche NetworkManager: <info>  (wlan0): now unmanaged
Jun 15 06:28:44 binoche NetworkManager: <info>  (wlan0): device state change: 8 -> 1
Jun 15 06:28:44 binoche NetworkManager: <info>  (wlan0): cleaning up...
Jun 15 06:28:44 binoche NetworkManager: <info>  (wlan0): taking down device.
Jun 15 06:28:44 binoche dhclient: receive_packet failed on wlan0: Network is down
Jun 15 06:28:44 binoche NetworkManager: <WARN>  remove_network_cb(): Couldn't
remove network from supplicant interface: The requested network does not exist..
Jun 15 06:28:45 binoche ntpd[2055]: ntpd exiting on signal 15


when it resumes, it starts the kernel, shows the initial booting kernel, the
switches to a virtual terminal and just shows a blinking cursor and the hard
disk just spins.  Nothing appears in the /var/log/messages after a hard reboot,
nor is there any kernel oops on the screen.  I don't know what's going on now.
Comment 12 Alex Lancaster 2008-06-15 10:00:11 EDT
Come to think of it, it doesn't show any swsup messages which is what is
normally shown on hibernation, but I *am* choosing the "Hibernation" option, not
"sleep".  I also tried pm-hibernation from the command-line and get the same issue.
Comment 13 Alex Lancaster 2008-10-16 19:35:59 EDT
Hibernation now works again in rawhide with this kernel:

kernel-2.6.27-3.fc10.i686

So closing bug.  Hooray!

Note You need to log in before you can comment on or make changes to this bug.