Bug 375151 - Traceback doing 'yum list available'
Summary: Traceback doing 'yum list available'
Status: CLOSED DUPLICATE of bug 378911
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum-rhn-plugin   
(Show other bugs)
Version: 5.1
Hardware: All
OS: Linux
low
high
Target Milestone: ---
: ---
Assignee: Justin Sherrill
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-11-10 22:49 UTC by Matthew Booth
Modified: 2007-11-27 14:52 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-27 14:52:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Matthew Booth 2007-11-10 22:49:09 UTC
Description of problem:
I type 'yum list available'. I get the following traceback every time (10th Nov
2007, 22:46 GMT).

Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 94, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 266, in doCommands
    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, sel
f.extcmds)
  File "/usr/share/yum-cli/yumcommands.py", line 160, in doCommand
    ypl = base.returnPkgLists(extcmds)
  File "/usr/share/yum-cli/cli.py", line 773, in returnPkgLists
    ypl = self.doPackageLists(pkgnarrow=pkgnarrow)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 1061, in doPacka
geLists
    avail = self.pkgSack.returnNewestByNameArch()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 479, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 359, in _getSack
s
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.4/site-packages/yum/repos.py", line 237, in populateSac
k
    sack.populate(repo, mdtype, callback, cacheonly)
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 141, in populate
    if self._check_db_version(repo, mydbtype):
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 198, in _check_db
_version
    if repo.repoXML.repoData.has_key(mdtype):
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 689, in <lambda>
    repoXML = property(fget=lambda self: self._getRepoXML(),
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 683, in _getRepoX
ML
    self._loadRepoXML(text=self)
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 666, in _loadRepo
XML
    cache=self.http_caching == 'all')
  File "/usr/lib/yum-plugins/rhnplugin.py", line 209, in _getFile
    start, end, copy_local, checkfunc, text, reget, cache)
  File "/usr/lib/yum-plugins/rhnplugin.py", line 298, in _noExceptionWrappingGet
    return result
UnboundLocalError: local variable 'result' referenced before assignment


Version-Release number of selected component (if applicable):
yum-rhn-plugin-0.5.2-3.el5.noarch

Comment 1 Justin Sherrill 2007-11-27 14:52:43 UTC

*** This bug has been marked as a duplicate of 378911 ***


Note You need to log in before you can comment on or make changes to this bug.