Bug 375171 - Kernel crash during F8 install from DVD [NEEDINFO]
Kernel crash during F8 install from DVD
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-10 17:51 EST by William M. Brack
Modified: 2009-01-09 00:08 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 00:08:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
davej: needinfo? (wbrack)


Attachments (Terms of Use)

  None (edit)
Description William M. Brack 2007-11-10 17:51:51 EST
Description of problem:
Kernel crash during install from DVD

Version-Release number of selected component (if applicable):
2.6.23.1-42.fc8

How reproducible:
Many attempts to accomplish installation. All failed. Under graphics install,
system froze.  Under text mode, received kernel crash dump.


Additional info:
I (manually) copied most info from screen. Excerpts:

EFLAGS: 00200292 (2.6.23.1-42.fc8 #1)

EIP is at _spin_unlock_irqrestore+0xa/0x13

Call trace:

ata_interrupt + 0x1ab/0x1be  [libata]
handle_IRQ_event + 0x23/0x51
handle_level_irq + 0x74/0xb9
handle_level_irq + 0x0/0xb9      (yes, appeared twice)
do_IRQ + 0x8c/0xb9
sys_write + 0x41/0x67
common_interrupt + 0x23/0x30

Kernel Panic - not syncing! Fatal exception in interrupt

I have registers and stack dump, but don't want to type it in unless it's needed
:-).

I loaded the DVD on a different system on the LAN and successfully completed the
install using http.
Comment 1 Dave Jones 2007-11-26 23:11:49 EST
hmm, strange. as it's the same kernel regardless of install method.
on your installed system, no strange messages from libata in the dmesg output?
Comment 2 tswan 2007-11-30 20:11:47 EST
I don't know if this is related.   But, I am getting a loader crash during the
install of F8-i386 from DVD media.  

When trying to install F8 on an HP laptop (in text mode)

loader received SIGSEGV! Backtrace:
[0x804a030]
[0x110420]
[0x81a3f42]
[0x805b750]
[0x805c153]
[0x804b207]
[0x8175004]
0x8048151]

Installing  in graphical mode yields the following error messages:
*** glibc detected *** /sbin/loader: munmap_chunk(): invalid pointer: 0x0850c810
=== Backgrace: ===
[0x81a4083]
[0x805b750]
[0x805c153]
[0x804b207]
[0x8175004]
[0x8048151]
======= Memory map =======
00110000-00111000 r-xp 001110000 00:00 0 [vdso]
08048000-0828e000 r-xp 00000000 00:01 36 /sbin/loader
0828e000-08299000 rw-p 00245000 00:01 36 /sbin/loader
08299000-082d3000 rw-p 08299000 00:00 0
0849b000-08589000 rw-p 0849b000 00:00 0
b7f36000-b7f39000 rw-p b7f36000 00:00 0
bfedb000-bfef0000 rw-p bffea000 00:00 0
loader received a SIGABRT!  Backtrace:
[0x804a030]
[0x110420]
[0x81e7f80]
[0x8182a30]
[0x819930b]
[0x81a4003]
[0x805b750]
[0x805c153]
[0x804b207]
[0x8175004]
[0x8048151]
install exited abnormally [1/1]

This exact same problem happens when installing from known good media on both
USB DVD drives and the local dvd drive. 
I am using the Fedora-8-i386-DVD.iso.  Memtest has been run on this system and
there are no memory errors.

This doesn't seem to be isolated. 
http://www.nabble.com/F8-Installation-Issue---Second-Try-tf4806216.html#a13750126 
Comment 3 Karl 2008-01-14 15:48:05 EST
It looks like I have stumbled upon this one aswell. The backtrace looks the same:

loader received SIGSEGV!  Backtrace:
[0x804a030]
[0x110420]
[0x81a3f42]
[0x805b750]
[0x805c153]
[0x804b207]
[0x8175004]
[0x8048151]
install exited abnormally [1/1]
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...
	/mnt/runtime done
	disabling /dev/loop0
	/proc/bus/usb done
	/proc done
	/dev/pts done
	/sys done
	/tmp/ramfs done
	/mnt/source done
	/selinux done
you may safely reboot your system

I'm trying to make a FC8 pxeboot installation on an HP laptop (nc6000).

Comment 4 Christopher Brown 2008-02-07 13:06:17 EST
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the Fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Have you tried using an
updated Fedora unity release which may resolve this problem?

http://spins.fedoraunity.org/spins

You may also wish to try Fedora 9 Alpha to see whether the issue is still
present and we can try and resolve it before F9 final.

http://fedoraproject.org/get-prerelease

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.
Comment 5 Karl 2008-03-15 12:45:35 EDT
I tried using the latest fedora spin available at the time with the same result.
I haven't tried Fedora 9 though. Since a new install didn't work I upgraded the
system instead.
Comment 6 Bug Zapper 2008-11-26 03:18:17 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Bug Zapper 2009-01-09 00:08:46 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.