Bug 375281 - Firefox not seeing extra installed true type fonts
Firefox not seeing extra installed true type fonts
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
8
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-10 20:06 EST by Daniel Rowe
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-13 03:48:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen shot of F8 Firefox page rendered (469.86 KB, image/png)
2007-11-12 07:23 EST, Daniel Rowe
no flags Details
Screen shot of tarball Firefox page rendered (399.45 KB, image/png)
2007-11-12 07:45 EST, Daniel Rowe
no flags Details

  None (edit)
Description Daniel Rowe 2007-11-10 20:06:29 EST
Description of problem:

Firefox in F7 is not using extra TTF when installed, the fonts are install
correctly as other apps can see them. If the i386 version of Firefox is download
from the Firefox site it does see the fonts and work correctly.

Version-Release number of selected component (if applicable):

firefox-2.0.0.8-2.fc8
Fedora 8 X86_64

How reproducible:

Everytime.

Steps to Reproduce:

1. Install TTF font like mscorefonts http://corefonts.sourceforge.net/.
2. Run Firefox, go to web sites and notice the new TTF are not being used.
3. Install and run the Firefox from www.mozilla.org,notice the fonts are being
used. 
  
Actual results:

The F8 Firefox is not using installed TTF.

Expected results:

To use the fonts.
Comment 1 Matěj Cepl 2007-11-12 05:09:03 EST
Cannot reproduce here. Could you please elaborate a little bit on the point 1)?
How did you install these fonts?

What's the output of the command

fc-match --sort 'Times New Roman'

Thanks.
Comment 2 Daniel Rowe 2007-11-12 07:21:21 EST
Hi

I build the RPM from http://corefonts.sourceforge.net/ and installed it.

Really strange and has got me stumped, the 32bit tar ball version of Firefox
from the mozilla site works fine with these fonts. The X86_64 F8 included
Firefox is not seeing the fonts or at least it is rendering pages differently
with what looks like different fonts. It renders the page the same no matter if
the fonts package is installed or not. I am using both version of Firefox with
the same profile so I don't think it is any settings.

I have attached some screen shots to show what I mean. The pages look different
between the versions. If I remove the mscorefonts the pages look the same on
both versions.

[root@bajor home]# fc-match --sort 'Times New Roman'
times.ttf: "Times New Roman" "Normal"
n021003l.pfb: "Nimbus Roman No9 L" "Regular"
DejaVuSerif.ttf: "DejaVu Serif" "Book"
luxirr.ttf: "Luxi Serif" "Regular"
lohit_bn.ttf: "Lohit Bengali" "Regular"
lohit_gu.ttf: "Lohit Gujarati" "Regular"
lohit_hi.ttf: "Lohit Hindi" "Regular"
lohit_pa.ttf: "Lohit Punjabi" "Regular"
lohit_ta.ttf: "Lohit Tamil" "Regular"
lohit_ml.ttf: "Lohit Malayalam" "Regular"
lohit_kn.ttf: "Lohit Kannada" "Regular"
lohit_te.ttf: "Lohit Telugu" "Regular"
lohit_or.ttf: "Lohit Oriya" "Regular"
lklug.ttf: "LKLUG" "Regular"
sazanami-gothic.ttf: "Sazanami Gothic" "Regular"
KacstArt.ttf: "KacstArt" "KacstArt"
gulim.ttf: "Baekmuk Gulim" "Regular"
arial.ttf: "Arial" "Normal"
cour.ttf: "Courier New" "Normal"
DejaVuSans.ttf: "DejaVu Sans" "Book"
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
PakTypeNaqsh.ttf: "PakTypeNaqsh" "Regular"
ariblk.ttf: "Arial Black" "Normal"
PakTypeTehreer.ttf: "PakTypeTehreer" "Regular"
uming.ttf: "文鼎PL細上海宋Uni" "Regular"
Jomolhari-alpha3c-0605331.ttf: "Jomolhari" "Regular"
s050000l.pfb: "Standard Symbols L" "Regular"
DejaVuLGCSans-ExtraLight.ttf: "DejaVu LGC Sans" "ExtraLight"
DejaVuSansMono-Bold.ttf: "DejaVu Sans Mono" "Bold"
6x12.pcf: "MiscFixed" "SemiCondensed"
6x13.pcf: "MiscFixed" "SemiCondensed"
9x15.pcf: "MiscFixed" "Regular"
console8x16.pcf: "Console" "Regular"
9x18.pcf: "MiscFixed" "Regular"
10x20.pcf: "MiscFixed" "Regular"
Comment 3 Daniel Rowe 2007-11-12 07:23:05 EST
Created attachment 255101 [details]
Screen shot of F8 Firefox page rendered
Comment 4 Daniel Rowe 2007-11-12 07:45:50 EST
Created attachment 255161 [details]
Screen shot of tarball Firefox page rendered
Comment 5 Matěj Cepl 2007-11-12 09:40:05 EST
Does running firefox as 

MOZ_DISABLE_PANGO=1 /usr/bin/firefox

make firefox to display the same as the one from Mozilla website?
Comment 6 Daniel Rowe 2007-11-12 21:39:14 EST
Hi

With MOZ_DISABLE_PANGO=1 /usr/bin/firefox it is displaying the fonts the same as
the Mozilla Firefox and working as it should.

Appears to be a pango problem?

Regards
Comment 7 Matěj Cepl 2007-11-13 03:48:41 EST
OK, so this is really and truly NOTABUG. What happens is that firefox always
dutifully uses your Microsoft fonts, but Pango version just displays everything
slightly differently (i.e., it displays the same font differently; and note that
Firefox from mozilla.org doesn't know Pango at all). Whether you prefer one to
another is another question, but that's basically your personal choice. There is
no definite position how the web page SHOULD look like and no definite "correct"
rendering of a font.

Closing as NOTABUG. If you have some reasons why the previous paragraphs is
false or whether I have ommitted some other problem, please reopen and explain
in the comment.

Note You need to log in before you can comment on or make changes to this bug.