This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 37531 - The installer cannot format and install RH 7.1 using AMI Megaraid 1600 (493) controller. Installs fine on IDE-drive
The installer cannot format and install RH 7.1 using AMI Megaraid 1600 (493) ...
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-25 02:47 EDT by Need Real Name
Modified: 2007-04-18 12:32 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-15 14:06:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-04-25 02:47:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0b; Windows NT 5.0)


I am trying to install RH 7.1 onto a server using the AMI MegaRAID 1600 
(493) card. The card gets detected, the drive array gets detected. After 
selecting the relevant packages, I go into using DiskDruid. However, I get 
the message that I have to initialize /dev/sda first. For this message to 
disappear, OK has to be pressed five times before you enter DiskDriud. I 
then select my partitions, and finally I press OK in order to install. The 
installer returns the message "Could not format /. This may be a serious 
error" and I have to reboot. Installing to an IDE-drive works fine, 
installing to the RAID-array using RH 7.0 works fine.

Reproducible: Always
Steps to Reproduce:
1. Boot and start the installer
2. Select Server or Custom install
3. If custom, select packages and partitions (using fdisk og DiskDruid)
4. Press OK in order to install
5. You will get the message "Could not format /. This may be a serious 
error"
	

Actual Results:  I had to reboot the computer, leaving the RAID-array in 
the same state as before installing. 

Expected Results:  Since RH 7.0 has a driver for the MegaRAID 1600 (493) 
controller, I assume that 7.1 also has this. The controller is detected 
and everything seems fine, but it just doesn't work.

RH 7.0 works like a dream, but when I try to compile the 2.4.3-ac9 kernel 
on this one, I get the same error (sda: unknown partition table, VFS: 
Cannot open root device "801" or 08:01 etc...)
The server is otherwise a standard box from Intel, dual P3-1ghz, 512mb 
RDIMM, AIC 7899, AMI Megaraid 1600 (493) with 5x36gb 10k drives.
Comment 1 Christophe Lesur 2001-04-25 04:15:20 EDT
I have exactly the same problem using an AMI MEGARAID 493 (Elite 1600) 
controleur with 64Mb onboard and RAID1 2x9Go.

In kernel 2.4.1, 2.4.2 and 2.4.3, the MEGARAID driver same to be broken.

All is perfect with Redhat 7.0 and 2.2 kernel.
Comment 2 Rafael Martinez 2001-04-27 05:09:56 EDT
Same problem with 128Mb onboard "RAID 5"  4x18Gb.

2.2.x --> OK
2.4.x --> sdb: unknown partition table
Comment 3 Christophe Lesur 2001-05-03 02:05:44 EDT
AMI help us to find what's wrong :

> -----Message d'origine-----
> De : Brian Highers [mailto:BrianH@ami.com]
> Envoyi : vendredi 27 avril 2001 01:24
> @ : 'Loic.Breat@INTRINsec.com'
> Cc : Peter Jarrett; Atul Mukker.; Venkatesh Ramamurthy
> Objet : RE: megaraid driver doesn't work with 2.4.x kernels
> 
> 
> Enclosed is a newer FW G158.   The issue that you reported as 
> well as some
> of the other posts is a known problem with FW L148. Please 
> upgrade to this
> newer firmware and this should address your issues.
> 
> Thanks
> BrianH

Using the new MEGARAID FIRMWARE G158 solve the problem.

I can sent the firmware by mail if someone want it.

Regards from France, Chris.
Comment 4 Rafael Martinez 2001-05-03 07:07:10 EDT
The last firmware version G158 is not available in the web
http://www.megatrends.com/ 
(I can only find  C158,-311 L148-311,H132-307)

Where can I get the last version for my card Ami Elite 1600? How can I
install the firmware? (There is no information about this neather) Do I need
windows to do this? 

I hope to get information soon, this production machine needs to be in
production as soon as possible and i can not use a 2.2.x kernel for this
(Files > 2GB)

Sincerely
Rafael Martinez
Comment 5 Arjan van de Ven 2001-05-03 07:37:59 EDT
I don't know when AMI will release a fixed firmware. However,
the Red Hat Linux 2.2.19 kernel does support files > 2 Gb.
Comment 6 Trond Eivind Glomsrxd 2001-05-03 08:36:48 EDT
Standard kernel, or just the enterprise one? It used to be that only the
enterprise kernel had LFS patches
Comment 7 Joseph Lazzaro 2001-05-03 21:37:43 EDT
I used C158 from AMI's site and it appears to have fixed it - at least enough 
to complete the install. Was G158 a typo?
Comment 8 Christophe Lesur 2001-05-04 02:19:15 EDT
No, i really have a G158. This is the release notes from G158 :

AMI MegaRAID Firmware Image Release
OEM Name:                   AMI 
Controllers Supported:      475/493/471/494/503/463/475LC
Engineering Release date:   04/13/2001
Released by:                Basavaraj / Chayan
New Release Version:        G158
BIOS Version:               3.11
Ctrl+M Version:             5.20
WebBIOS Version:            1.38
Boot ROM Version:           1.2.7 (AMI specific)
Qlogic 12160 F/w version:   11.12.130 (11:32 Apr 02, 2001)
Previous Official Release:  F158/3.11/5.20/1.38


Controllers Supported:
======================
Series 463   = MegaRAID Express 550 
Series 471   = MegaRAID Enterprise 1600
Series 475   = MegaRAID Express 500
Series 475LC = MegaRAID Express 500LC
Series 493   = MegaRAID Elite 1600
Series 494   = MegaRAID Elite 1650
Series 503   = MegaRAID Enterprise 1700


Firmware Changes
================
Changes in G158 (based on F158 below)
   1. QLogic firmware changed from 11.12.13 to 11.12.130
   
   NEC471PR010  
   2. From Russel Foster:
      Here is the updated bbu493 code which has the period in between 
monitoring 
      cycles extended. This should eliminate the recurrent messages. 
      
   
   NEC471021
   3. Recovery Sequence: 
      When Medium Error occurs on Read, the RAID F/W recovers the data from 
other 
      disks and fires a WRITE_VERIFY command. Due to a bug, it was issuing 
      WRITE_VERIFY only if the channel is a fibre channel. It is now fixed to 
      issue WRITE_VEIFIFY to scsi channels too.
-----------------------------------------------------------------------


Comment 9 Christophe Lesur 2001-05-04 09:36:01 EDT
It seems that with the G158 firmware, we have many "READ ERRORS" problem on the 
LOGICAL Drive :(((((((

We will try the C158 firmware soon.

bouuuuu....
Comment 10 Christophe Lesur 2001-05-08 12:30:00 EDT
All appears to be ok with FIRMWARE C158.

no more I/O Errors.

Chris.
Comment 11 Arjan van de Ven 2001-05-08 12:33:48 EDT
AMI recommends everybody who uses the "148" firmware to immediately upgrade
to a 158 version, the problems are indeed purely firmware based.
Comment 12 Fred Pishotta 2001-05-15 14:06:53 EDT
Further confirmation...

Yes, I had the same problem trying to install RH 7.1 onto my system
which is using the Elite 1600 RAID card as its sole disk controller.
Installation would complain that it couldn't figure out the "unknown
partition table" and exited.

Following advice found here, I downloaded the C158 firmware upgrade
from the download page at http://www.megaraid.com, performed the
upgrade (which was a little tricky loading on a floppy along with the
system files required for booting -- I dumped the readme.txt file 
and "drivespace.sys" [I think it was or some similarly named thing]),
and the 7.1 release installed just fine from the CDs.

-- Fred P.
Comment 13 Arjan van de Ven 2001-05-16 12:46:29 EDT
I'd like to close this as "NOTOURBUG", but that doesn't exist -> "NOTABUG"

Note You need to log in before you can comment on or make changes to this bug.