Bug 375421 - Error: Missing Dependency: kernel-i686 = 2.6.23.1-49.fc8 is needed by package kmod-nvidia-2.6.23.1-49.fc8
Error: Missing Dependency: kernel-i686 = 2.6.23.1-49.fc8 is needed by package...
Status: CLOSED DUPLICATE of bug 330711
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
8
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-10 23:06 EST by Landon Kelsey
Modified: 2014-01-21 18:00 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-14 15:22:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Landon Kelsey 2007-11-10 23:06:42 EST
Description of problem:
[landon4@x1-6-00-b0-d0-16-1c-01 QtFigs4]$ su -
Password:
[root@x1-6-00-b0-d0-16-1c-01 ~]# yum update
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package kmod-nvidia.i686 0:100.14.19-18.lvn8 set to be updated
--> Processing Dependency: kmod-nvidia-2.6.23.1-49.fc8 for package: kmod-nvidia
--> Running transaction check
---> Package kmod-nvidia-2.6.23.1-49.fc8.i686 0:100.14.19-18.lvn8 set to be updated
--> Processing Dependency: kernel-i686 = 2.6.23.1-49.fc8 for package:
kmod-nvidia-2.6.23.1-49.fc8
--> Finished Dependency Resolution
Error: Missing Dependency: kernel-i686 = 2.6.23.1-49.fc8 is needed by package
kmod-nvidia-2.6.23.1-49.fc8
[root@x1-6-00-b0-d0-16-1c-01 ~]#



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce: yum update
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Alexei Podtelezhnikov 2007-11-10 23:22:16 EST
something is wrong with a mirror. I have that kernel installed.
yum clean all
yum update
Comment 2 Simon Roberts 2007-11-11 00:49:06 EST
kmod-nvidia is from livna, and it is dependent on a kernel package that isn't
available on most mirrors yet.
Comment 3 Landon Kelsey 2007-11-11 01:06:37 EST
this:

yum install kmod-nvidia

worked fine after installing F8

and solved the problem of the screensaver running slow (same problem on F7

This yum install kmod-nvidia was recommended on the Mauriat Miranda site for F8
Comment 4 Dan Emmons 2007-11-13 06:23:06 EST
yum updates are breaking dependencies with livna kmods now, i think, because
something is making yum try to remove the old kernel when it updates to a new
one. since i started using fc6, it has always allowed the latest kernel to live
side by side with the one it replaced for safety. this stopped when i installed
f8. we can  download the kernel manually and install with rpm -i though, i hear.
Comment 5 Landon Kelsey 2007-11-13 11:55:22 EST
true?

(1) I installed F8 and the automatic yum did an instant update

(2) I installed livna

(3) I did a yum install kmod-nvidia (details on the other OS) and solved my 
screensaver running too slow)

(4) and later came a automatic yum update that got the error

I had seen no kernel updates at any point
Comment 6 Florian Festi 2007-11-14 07:55:24 EST
(In reply to comment #4)
install_only moved to the yum core and no longer is a yum plugin. If you just
updated you installation you might need to adjust your configuration to reflect
that. Have a look into the yum config files shipped with the current yum.
Comment 7 Thorsten Leemhuis 2007-11-14 15:22:21 EST
the initial comment in this bug looks like mirror issues (the kmod from livna
was available before the Fedora mirror had the matching kernel for it)

Comment #4 is likely about Bug 330711 

Comment #5 -- no idea what that's about without a detailed error message, but
likely 330711 as well

*** This bug has been marked as a duplicate of 330711 ***

Note You need to log in before you can comment on or make changes to this bug.