Bug 375471 - Dell touchpad not detected as touchpad
Dell touchpad not detected as touchpad
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-11 00:09 EST by Jacob Masaki
Modified: 2007-12-05 15:43 EST (History)
0 users

See Also:
Fixed In Version: 2.6.23.8-63.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-05 15:43:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jacob Masaki 2007-11-11 00:09:53 EST
Description of problem:


Version-Release number of selected component Kernel 2.23.1-49:


How reproducible:


Steps to Reproduce:
1. Install Fedora 8 + Updates
2. Find that xorg won't load the "synaptics" driver because it thinks the
touchpad can't use synaptics.  
  
Actual results:
Touchpad is thought to be a normal mouse.  

Expected results:
Touchpad is though to be a touchpad, so scrolling works and such.  

Additional info:
http://lkml.org/lkml/2007/8/4/184 Talks about a possible fix, but I haven't
tried it, as I've never compiled a kernel before, and am worried I will render
my laptop unbootable.  

I also looked at the Ubuntu source (Ubuntu works with the touchpad) and they
appear to have applied this patch in the alps.c (and a couple others, which I
hope are unrelated...)
Comment 1 Chuck Ebbert 2007-11-12 17:28:16 EST
patch queued for next kernel update.
Comment 2 Aniket 2007-11-17 05:33:00 EST
I can also confirm this bug with kernel 2.23.1-49 on my Dell Vostro 1400 with 
FC8 and all updates installed. 
Comment 3 Simon Perry 2007-11-19 17:19:48 EST
Can confirm that trackpad scrolling etc for Dell Inspiron 1420 now works with
kernel 2.6.23.1-58 (was not working with 2.6.23.1-49).

Some of the numbers for the synaptics driver options in xorg.conf have to be
tweaked quite a bit to get it usable, but once that's done it works ok.
Comment 4 Chuck Ebbert 2007-11-21 14:30:59 EST
In 2.6.23.8-62

Note You need to log in before you can comment on or make changes to this bug.