Bug 375511 - upgrade to F8 fails to remove old avahi
upgrade to F8 fails to remove old avahi
Status: CLOSED DUPLICATE of bug 366891
Product: Fedora
Classification: Fedora
Component: avahi (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Martin Bacovsky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-11 00:34 EST by Claude Jones
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-11 13:01:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Claude Jones 2007-11-11 00:34:51 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.8) Gecko/20071030 Fedora/2.0.0.8-2.fc8 Firefox/2.0.0.8

Description of problem:
On two separate machines, upgrades to F8 from F7, done via Yum, resulted in a failure to delete or overwrite avahi. This what I now have after the update:

# rpm -qa | grep avahi
avahi-0.6.21-6.fc8
avahi-qt3-0.6.21-6.fc8
avahi-compat-howl-0.6.21-6.fc8
avahi-compat-libdns_sd-0.6.21-6.fc8
avahi-devel-0.6.21-6.fc8
kdnssd-avahi-devel-0.1.3-0.2.20060713svn.fc8
kdnssd-avahi-0.1.3-0.2.20060713svn.fc8
avahi-0.6.17-1.fc7
avahi-glib-0.6.21-6.fc8

So, I have two versions of avahi, now - the fc7 and fc8 
Attempts to remove avahi-0.6.17-1.fc7 result in an error:

# rpm -e avahi-0.6.17-1.fc7
error: %postun(avahi-0.6.17-1.fc7.i386) scriptlet failed, exit stat

Version-Release number of selected component (if applicable):
avahi-0.6.21-6.fc8

How reproducible:
Always


Steps to Reproduce:
1. Upgrade F7 to F8
2. Error messages regarding failure to delete old avahi are producedd
3.

Actual Results:
two versions of avahi are now on my system

Expected Results:
the F7 version of Avahi should have been removed

Additional info:
I've tried various package managers such as smart, yum, rpm, yumex, and kpackage to remove the old avanti. All produce the same error when trying to remove the earlier avanti version. This is on  two completely separate machines. Both these machines were upgraded to F8 via yum, in the past couple of days. Both these machines are generally running quite well, otherwise
Comment 1 Claude Jones 2007-11-11 00:36:42 EST
I've also tried booting into runlevel 1 to see if I could delete the app from
there, but it didn't work. 
Comment 2 Lennart Poettering 2007-11-11 13:01:02 EST
Duplicate

*** This bug has been marked as a duplicate of 366891 ***

Note You need to log in before you can comment on or make changes to this bug.