Bug 375681 - scratchbox doesn't work on F8
scratchbox doesn't work on F8
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-11 05:28 EST by Stelian Iancu
Modified: 2008-01-21 21:26 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-21 21:26:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Stelian Iancu 2007-11-11 05:28:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.8) Gecko/20071030 Fedora/2.0.0.8-2.fc8 Firefox/2.0.0.8

Description of problem:
The current stable version of scratchbox (http://www.scratchbox.org) doesn't work in F8.

When I try to do /scratchbox/login, I get the following:

Inconsistency detected by ld.so: rtld.c: 1192: dl_main: Assertion `(void *) ph->p_vaddr == _rtld_local._dl_sysinfo_dso' failed!

This bug is caused by VDSO compat not being enabled in the kernel (see also https://launchpad.net/ubuntu/+source/linux-source-2.6.20/+bug/86457). 

Version-Release number of selected component (if applicable):
kernel-2.6.23.1-42.fc8

How reproducible:
Always


Steps to Reproduce:
1. Install scratchbox from http://www.scratchbox.org/download/scratchbox-apophis/
2. After installing it, run /scratchbox/login


Actual Results:
The following error appears:

[stelu@thor maemo]$ /scratchbox/login 
Inconsistency detected by ld.so: rtld.c: 1192: dl_main: Assertion `(void *) ph->p_vaddr == _rtld_local._dl_sysinfo_dso' failed!

You dont have active target in scratchbox chroot.
Please create one by running "sb-menu" before continuing


Welcome to Scratchbox, the cross-compilation toolkit!

Use 'sb-menu' to change your compilation target.
See /scratchbox/doc/ for documentation.

Inconsistency detected by ld.so: rtld.c: 1192: dl_main: Assertion `(void *) ph->p_vaddr == _rtld_local._dl_sysinfo_dso' failed!
Inconsistency detected by ld.so: rtld.c: 1192: dl_main: Assertion `(void *) ph->p_vaddr == _rtld_local._dl_sysinfo_dso' failed!
Inconsistency detected by ld.so: rtld.c: 1192: dl_main: Assertion `(void *) ph->p_vaddr == _rtld_local._dl_sysinfo_dso' failed!


Expected Results:
It should have worked :-)

Additional info:
Comment 1 Chuck Ebbert 2007-11-12 17:40:13 EST
Try adding:

  vdso=2

to the kernel boot options, but be aware that this can reduce the security of
your system.
Comment 2 Stelian Iancu 2007-11-13 18:03:32 EST
Tried that, now the kernel doesn't boot anymore. I get this:

init[1] general protection eip:30d7d9 esp:bfe9635c error:0

Any idea what else can I try?

Thanks!
Comment 3 Chuck Ebbert 2007-11-19 15:58:47 EST
Try this command as root after booting:

# sysctl vm.vdso_enabled=2
Comment 4 Stelian Iancu 2007-11-19 17:32:45 EST
After entering that command, everything segfaults afterwards.
Comment 5 Dave Jones 2007-11-26 23:00:28 EST
vdso=off ?
Comment 6 Chuck Ebbert 2007-12-04 13:56:24 EST
Did "vdso=off" work?
Comment 7 Stelian Iancu 2007-12-04 15:50:49 EST
I am really sorry, but I didn't have a chance to try it yet. I've been traveling
all this time. However, tomorrow I get home (it's my desktop computer) and I'll
give it a shot.

Many thanks for the suggestion and the patience!

Regards,
Stelian
Comment 8 Thomas Sailer 2007-12-04 16:08:38 EST
vdso=2 works for me with a slightly modified 2.6.23.9-67.fc8 (includes an 
rndis backport from linus git, unrelated to anything arch specific)
Comment 9 Stelian Iancu 2007-12-06 16:39:21 EST
vdso=off works. Thanks!

This bug can be closed now. Should I close it?
Comment 10 Jon Stanley 2008-01-06 13:57:24 EST
*** Bug 427641 has been marked as a duplicate of this bug. ***
Comment 11 Jon Stanley 2008-01-21 21:26:03 EST
closing bug per reporter comment #9

Note You need to log in before you can comment on or make changes to this bug.