Bug 375691 - gnome-panel-2.20.1's pager no longer has compiz support
gnome-panel-2.20.1's pager no longer has compiz support
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-11 05:46 EST by drago01
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.20.1-2.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-20 13:10:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gnome-panel.spec patch (1.23 KB, patch)
2007-11-11 06:21 EST, drago01
no flags Details | Diff
gnome-panel-2.20.1-compiz-support.patch (85.15 KB, patch)
2007-11-11 06:22 EST, drago01
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 496830 None None None Never

  None (edit)
Description drago01 2007-11-11 05:46:28 EST
Description of problem:
In F7 gnome-panel was shipped with "gnome-panel-2.16.0-compiz-support.patch"
which made it possible to change the number of view ports in compiz using the
pager and also looked differently (no separators). In F8 the patch is dropped
and the user experience with it is worse. The patch does not apply as is (tried
to rebase it but it seems that the glade file changed completely) 

Can this patch be ported to gnome-panel-2.20 and enabled again in the builds?
Comment 1 drago01 2007-11-11 06:20:40 EST
Ok I managed to port the patch to 2.20, I will attach both a patch to the
specfile and one the updated gnome-panel-compiz-support patch. I tested it and
it seems to work fine (both with metacity and compiz).
Comment 2 drago01 2007-11-11 06:21:34 EST
Created attachment 254401 [details]
gnome-panel.spec patch

This patches the gnome-panel.spec file to apply the new patch.
Comment 3 drago01 2007-11-11 06:22:48 EST
Created attachment 254411 [details]
gnome-panel-2.20.1-compiz-support.patch

This is the updated patch that apply, builds and runs fine to 2.20.1.
Comment 4 Matthias Clasen 2007-11-11 15:53:59 EST
We don't want to keep patching compiz functionality into the panel. The right
cause of action is to get these improvements into the upstream panel code.
Comment 5 drago01 2007-11-11 17:47:48 EST
thats true but we can't just silently drop a feature from release to release
(i.e introduce a regression). Can we add this patch to the f8 release and try to
get it upstream for f9 ? I doubt upstream will accept a patch like this for a
2.20.x release but its more likely for 2.22.
Comment 6 Ray Strode [halfline] 2007-11-11 21:38:11 EST
So, I'm definitely against having a lot of patches that diverge from upstream.

On the other hand, we normally file an upstream bug report when we add a patch
and wait for upstream to respond. If they approve of the patch it gets
upstreamed, if they don't we drop the patch from our rpm.

Apparently that didn't happen this time around?  I'm guessing the patch was
never submitted upstream and was eventually dropped when it stopped applying.

drago01, since you've already done the footwork to bring the patch back, would
you mind pushing it out as an F8 update?

We should definitely try to get the patch upstream this time too...
Comment 7 drago01 2007-11-12 11:15:32 EST
(In reply to comment #6)
> So, I'm definitely against having a lot of patches that diverge from upstream.
> 
> On the other hand, we normally file an upstream bug report when we add a patch
> and wait for upstream to respond. If they approve of the patch it gets
> upstreamed, if they don't we drop the patch from our rpm.
> 

Who wrote the original patch? Shouldn't the author fill the upstream bug? If not
I can do this too if nobody else (which is more involved upstream than I am)
want to do it.

> 
> drago01, since you've already done the footwork to bring the patch back, would
> you mind pushing it out as an F8 update?

Ok, working on it.

> We should definitely try to get the patch upstream this time too...
+1

Comment 8 Ray Strode [halfline] 2007-11-12 11:41:09 EST
krh, did you do the original patch?

If no one else wants to file the upstream report I can do it.
Comment 9 Fedora Update System 2007-11-12 18:59:47 EST
gnome-panel-2.20.1-2.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnome-panel'
Comment 10 Fedora Update System 2007-11-20 13:10:31 EST
gnome-panel-2.20.1-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.