Bug 375901 - missing dependency: libxml2-python
missing dependency: libxml2-python
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: setroubleshoot (Show other bugs)
7
i386 Linux
low Severity medium
: ---
: ---
Assigned To: John Dennis
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-11 08:44 EST by Dean Mander
Modified: 2008-01-09 12:02 EST (History)
0 users

See Also:
Fixed In Version: 1.10.7-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-09 12:02:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dean Mander 2007-11-11 08:44:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.8) Gecko/20071019 Fedora/2.0.0.8-1.fc7 Firefox/2.0.0.8

Description of problem:
$ sealert -a audit.log
Traceback (most recent call last):
  File "/usr/bin/sealert", line 45, in <module>
    from setroubleshoot.analyze import *
  File "/usr/lib/python2.5/site-packages/setroubleshoot/analyze.py", line 35, in <module>
    from setroubleshoot.avc_audit import *
  File "/usr/lib/python2.5/site-packages/setroubleshoot/avc_audit.py", line 35, in <module>
    from setroubleshoot.signature import AVC, AvcContext
  File "/usr/lib/python2.5/site-packages/setroubleshoot/signature.py", line 75, in <module>
    import libxml2
ImportError: No module named libxml2

$ yum -y install libxml2-python

$ sealert -a audit.log
100% done
found 50 alerts in audit.log


Version-Release number of selected component (if applicable):
setroubleshoot.noarch 0:1.9.4-2.fc7

How reproducible:
Always


Steps to Reproduce:
1. remove libxml2-python
2. run sealert

Actual Results:


Expected Results:


Additional info:
Comment 1 John Dennis 2007-11-30 11:08:33 EST
The requires for libxml2-python was in the most current F-7 version 1.10.6-1,
but that version had to be pulled because it had a dependency on selinux-policy
being at least 2.6.4-45 was wasn't available at the time. That version has since
become available. At that time setroubleshoot-1.10.6-1 should probably have been
repushed, but it wasn't.

Perhaps you might like to try installing setroubleshoot-1.10.6-1 and report back
if you have any problems. You can download it here:

http://koji.fedoraproject.org/koji/buildinfo?buildID=19682

The analysis plugins were split out into their own package so you'll need to
satisfy the dependency on setroubleshoot-plugins, the F-7 version can be
obtained here:

http://koji.fedoraproject.org/koji/buildinfo?buildID=15769
Comment 2 Dean Mander 2007-11-30 11:50:00 EST
I've upgraded to F-8 in the meanwhile, using 1.10.7-1.fc8.
In this version the dependency is set and, so to me the problem is solved.
Thanks!

Note You need to log in before you can comment on or make changes to this bug.