Bug 375911 - KMail crash while viewing email
KMail crash while viewing email
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kdepim (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-11 08:44 EST by Sven Borkert
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version: 3.5.8-10.svn20071129.ent.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-12 15:02:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sven Borkert 2007-11-11 08:44:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.5; Linux) KHTML/3.5.8 (like Gecko)

Description of problem:
(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1209149744 (LWP 5780)]
[New Thread -1244988528 (LWP 5784)]
[New Thread -1234498672 (LWP 5783)]
[New Thread -1224008816 (LWP 5782)]
[New Thread -1213518960 (LWP 5781)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6  0x00f7505e in QGDict::look_string ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#7  0x00340087 in KMHeaders::msgRemoved () from /usr/lib/libkmailprivate.so
#8  0x00346b99 in KMHeaders::qt_invoke () from /usr/lib/libkmailprivate.so
#9  0x00c75b8a in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#10 0x0037a980 in KMFolder::msgRemoved () from /usr/lib/libkmailprivate.so
#11 0x0037b60d in KMFolder::qt_emit () from /usr/lib/libkmailprivate.so
#12 0x00c75bce in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#13 0x0039ada0 in FolderStorage::msgRemoved ()
   from /usr/lib/libkmailprivate.so
#14 0x0039ca13 in FolderStorage::take () from /usr/lib/libkmailprivate.so
#15 0x004343f0 in KMFolderImap::take () from /usr/lib/libkmailprivate.so
#16 0x0037907e in KMFolder::take () from /usr/lib/libkmailprivate.so
#17 0x003c8c6d in KMFilterMgr::endFiltering ()
   from /usr/lib/libkmailprivate.so
#18 0x003ca138 in KMFilterMgr::process () from /usr/lib/libkmailprivate.so
#19 0x004171bd in KMAcctImap::slotFilterMsg ()
   from /usr/lib/libkmailprivate.so
#20 0x00418b80 in KMAcctImap::qt_invoke () from /usr/lib/libkmailprivate.so
#21 0x00c75b8a in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#22 0x0051c01e in KMail::FolderJob::messageRetrieved ()
   from /usr/lib/libkmailprivate.so
#23 0x00526da0 in KMail::ImapJob::slotGetMessageResult ()
   from /usr/lib/libkmailprivate.so
#24 0x00527cc5 in KMail::ImapJob::qt_invoke ()
   from /usr/lib/libkmailprivate.so
#25 0x00c75b8a in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#26 0x0172bbae in KIO::Job::result () from /usr/lib/libkio.so.4
#27 0x0177121d in KIO::Job::emitResult () from /usr/lib/libkio.so.4
#28 0x0179026e in KIO::SimpleJob::slotFinished () from /usr/lib/libkio.so.4
#29 0x0179097d in KIO::TransferJob::slotFinished () from /usr/lib/libkio.so.4
#30 0x01770e4a in KIO::TransferJob::qt_invoke () from /usr/lib/libkio.so.4
#31 0x00c75b8a in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#32 0x00c7657d in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#33 0x0172726c in KIO::SlaveInterface::finished () from /usr/lib/libkio.so.4
#34 0x017883d0 in KIO::SlaveInterface::dispatch () from /usr/lib/libkio.so.4
#35 0x0179d48a in KIO::SlaveInterface::dispatch () from /usr/lib/libkio.so.4
#36 0x0173d64c in KIO::Slave::gotInput () from /usr/lib/libkio.so.4
#37 0x0177fd60 in KIO::Slave::qt_invoke () from /usr/lib/libkio.so.4
#38 0x00c75b8a in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#39 0x00c76422 in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#40 0x01004170 in QSocketNotifier::activated ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#41 0x00c96570 in QSocketNotifier::event ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#42 0x00c0c38b in QApplication::internalNotify ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#43 0x00c0d941 in QApplication::notify ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#44 0x008eae82 in KApplication::notify () from /usr/lib/libkdecore.so.4
#45 0x00bffc91 in QEventLoop::activateSocketNotifiers ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#46 0x00bb3d31 in QEventLoop::processEvents ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#47 0x00c25c60 in QEventLoop::enterLoop ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#48 0x00c25b16 in QEventLoop::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#49 0x00c0bfcf in QApplication::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#50 0x0804a09e in QObject::checkConnectArgs ()
#51 0x06aea390 in __libc_start_main () from /lib/libc.so.6
#52 0x08049dd1 in QObject::checkConnectArgs ()


Version-Release number of selected component (if applicable):
kdepim-3.5.8-4.svn20071013.ent.fc

How reproducible:
Couldn't Reproduce


Steps to Reproduce:
I don't know how to reproduce the problem, KMail just crashed while I was 
reading email.

Actual Results:


Expected Results:


Additional info:
Comment 1 Rex Dieter 2007-11-11 15:21:10 EST
If it's not repeatable/reproducible, I'm not sure what good there is to pursue
this, but... regardless, if you consider it serious enough, please submit this
upstream to bugs.kde.org, that's where the kdepim developers can/will see it
(they won't here).
Comment 2 Rex Dieter 2007-11-29 19:56:26 EST
Can you try out this test (F8) build:
http://koji.fedoraproject.org/koji/buildinfo?buildID=26132
Comment 3 Fedora Update System 2007-12-03 00:35:03 EST
kdepim-3.5.8-10.svn20071129.ent.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdepim'
Comment 4 Fedora Update System 2007-12-12 15:02:38 EST
kdepim-3.5.8-10.svn20071129.ent.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.