Bug 375931 - rpm database corrupt after insatllation
rpm database corrupt after insatllation
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
8
All Linux
low Severity urgent
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-11 09:08 EST by The Source
Modified: 2008-04-01 08:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-01 08:04:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description The Source 2007-11-11 09:08:24 EST
Description of problem:
Fedora 8 is unusable. Xorg exits immediately after start (no EE in log however).
And when I tried to update it with yum, rpm said 'fatal error, run db rebuild'
or something like that. I don't want to here anything about hardware problems -
I don't have them. My system is rock stable. Great job, guys! Continue doing
such things and your project will die.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Panu Matilainen 2007-11-12 01:23:16 EST
Flaming isn't the best way to get people to look at your problems you know.
Try this as the first step: http://wiki.rpm.org/Docs/RpmRecovery
Comment 2 The Source 2007-11-12 01:59:50 EST
Yes, rpm --rebuilddb helped. rpm now shows installed packages properly. I will
try to update now. I just don't understand why this problem appeared in the
first place. Did the installer do something wrong, I went to forum to ask about
Xorg problem and found HUGE amount of threads about Fedora 8 problems. Perhaps
you, guys, were to hurry to release. Obviously much more testing was needed.
Comment 3 Panu Matilainen 2007-11-12 03:33:21 EST
Was this a fresh installation of F8 or upgrade from some earlier version (F7,
F8-test-something, rawhide...) and what kind of system is it (architecture etc)?
Comment 4 The Source 2007-11-12 03:51:36 EST
This is fresh installation.
My system:
ASUS P5B Plus Vista Edition motherboard
Core 2 Duo E6600 2.4 GHz
2GB ram 800MHz Dual
NVIDIA GeForce 8800 GTX
Creative Audigy 4

I installed i386 (32 bit intel) version of Fedora 8.
Comment 5 The Source 2007-11-14 03:01:52 EST
I was able to finally start fedora 8 after installing it in text mode (which
didn't  download anything additional even when I set to do it by the way). But
when I tried to update system with pup it showed many unresolved dependencies
(what the...?). I closed pup and launched it again. It said that rpm db is
corrupt. I tried rpm --rebuilddb but no luck - message about fatal error instead
of db rebuilding. Rpm is MEGA-UNSTABLE. Fedora 8 is unusable.
Comment 6 Panu Matilainen 2007-11-14 04:41:00 EST
That rpmdb corruption happens on your system doesn't mean it happens everywhere. 

This looks fairly similar to bug 230362, but so far there aren't really any
clues what's so different on these systems to everything else.
These kind of problems are usually due to the mmap()'ed db environment getting
somehow screwed up, which can happen due to kernel (driver and otherwise) and
glibc bugs: there was a huge amount of "rpmdb is corrupted" troubles about a
year ago where the real bug turned out to be in kernel (2.6.18 and thereabouts)
mmap implementation. The point: it's not as simple as "rpm is unstable and buggy".

One thing you could try is installing x86_64 version and see if the corruption
happens there too. If not, that'd be a valuable data point.
Comment 7 The Source 2007-11-14 05:06:49 EST
I'll try that
Comment 8 The Source 2007-11-14 08:26:36 EST
The system starts normally but I can't update kernel even from local file using
rpm -U. Db becomes corrupt on this attempt but after system restart db works
fine again. Looks like the actual error is somewhere in memory, not on disk. I
will compile and install new kernel from source and try to update system with it
and say if it makes any difference.
Comment 9 The Source 2007-11-14 09:49:06 EST
No, compiling and installing updated kernel from fedora 8 repo does not help. I
can't update any package - rpm says db is corrupt. Then again after reboot db is
fine and I can make query operations on it.
Comment 10 Eric Sandeen 2007-11-14 22:52:19 EST
If you check the filesystem (boot the install cd with "linux rescue" at the boot
prompt, then fsck) does anything show up?

-Eric
Comment 11 The Source 2007-11-15 11:23:38 EST
No, no errors were found.
Comment 12 The Source 2007-11-16 08:24:16 EST
I was able to get rid of the problem by running rpm --rebuilddb right after
system start before anything bad happens. Now rpm works fine. Perhaps updating
the kernel helped. I'll leave this issue open for a few days in case of
something else shows up.
Comment 13 Panu Matilainen 2008-04-01 08:04:05 EDT
Closing due to inactivity, comment #12 indicates this was some sort of temporary
issue possibly with kernel or whatever.

Note You need to log in before you can comment on or make changes to this bug.