Bug 376011 - sound fails to come back after suspend
sound fails to come back after suspend
Status: CLOSED DUPLICATE of bug 384271
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-11 09:40 EST by Luis Villa
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-17 20:04:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lshal in case it is HW-specific. (113.78 KB, text/plain)
2007-11-11 09:40 EST, Luis Villa
no flags Details

  None (edit)
Description Luis Villa 2007-11-11 09:40:34 EST
After my laptop suspends, it often (though as far as I can tell not quite 100%
of the time?) does not get sound back.

gnome-volume-control errors out with:
"No volume control GStreamer plugins and/or devices found."

rhythmbox says:
"Couldn't stop playback
Unknown playback error"

etc.

I don't need to reboot to fix it, just log out and log back in. Still, very
irritating.

lshal attached in case this is somehow hardware-specific. [Some other bugs
suggest that this might be the case, but I can't find any with my specific
hardware.]

[Filed against the kernel because I have no idea who else is responsible for
suspend behavior.]
Comment 1 Luis Villa 2007-11-11 09:40:34 EST
Created attachment 254671 [details]
lshal in case it is HW-specific.
Comment 2 Benjamin Thery 2007-11-15 03:34:14 EST
I have the same problem after hibernating (haven't try suspend).
When my laptop wake up after hibernation, audio is broken in my running
session.

As Luis said "just log out and log back in" fixes the problem.

I suspect PulseAudio to be the culprit (or something related to it).
Indeed, I see in my session profile there is a startup entry called 
"PulseAudio Session Management" which load module-x11-xsmp into PulseAudio
when it log back in.
Comment 3 Jack Spaar 2007-11-17 19:50:31 EST
It looks to me like a permissions problem.  See:
https://bugzilla.redhat.com/show_bug.cgi?id=384271
Comment 4 Luis Villa 2007-11-17 20:04:55 EST
That is in fact the problem; marking as dup since that one has the correct
diagnosis.

*** This bug has been marked as a duplicate of 384271 ***

Note You need to log in before you can comment on or make changes to this bug.