Bug 376031 - Clicking setroubleshoot (?) avc denial icon in tray does nothing
Clicking setroubleshoot (?) avc denial icon in tray does nothing
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: setroubleshoot (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: John Dennis
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-11 10:24 EST by Ville Skyttä
Modified: 2008-01-15 18:34 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-10 17:01:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2007-11-11 10:24:55 EST
In my F8, KDE, SELinux in permissive mode setup, I get a star icon in my systray
every now and then, with the tooltip "SELinux AVC denial, click to view".  When
I click it, nothing is shown, the icon just goes away.  The setroubleshoot
service is running.

setroubleshoot-1.10.7-1.fc8.noarch
Comment 1 John Dennis 2007-11-12 10:52:06 EST
If you don't mind could you do me a favor and log in under gnome once and see if
the problem goes away. In the past KDE has had numerous problems with the
notification applets.
Comment 2 Ville Skyttä 2007-11-12 12:59:58 EST
Same thing in GNOME, nothing happens.  My GNOME setup is probably somewhat
broken though (at least some icons are broken), I didn't even have it installed
and just did "smart install gnome-session" to get some packages installed so I
could choose GNOME from kdm's session menu and login.
Comment 3 Paul Black 2007-11-22 10:41:08 EST
Am also seeing this on a couple of machines - both running KDE. This used to
work under F8 (or possibly one of the test releases); I don't know if an update
or purging GNOME (and GDM) introduced the issue.
Comment 4 John Dennis 2008-01-09 16:14:03 EST
Is this still happening?

First of all please make sure you haven't iconified the sealert browser window.
If the winodow is already open (even if inconified) clicking the star won't do
anything because the application window is already open.

If that's not the case then let's verify the sealert process is running in your
session,

% ps ax | grep sealert 

should show one sealert process.

If it's there good, then click on the star. Is the sealert process still
running? Maybe it died for some reason.

What happens if you invoke sealert from the Menu? (e.g. Applications-->System
Tools-->SELinux Troubleshooter. Does that open the sealert browser window?

If you think sealert is dying, let's try and get diagnostic information. Kill
any running sealert programs, then run sealert in the foreground via:

% sealert -s -V

Try to open the browser again, anything in the debug output suspicious?
Comment 5 Ville Skyttä 2008-01-10 16:50:25 EST
I had removed all setroubleshoot* packages since they weren't helpful for me and
I found that dropping them allowed me to remove a bunch of other packages that I
have no use for.  But I just reinstalled the whole shebang to verify this, and
after "smart install setroubleshoot", start of auditd and setroubleshoot, and
logging out and back in, it works.  So as far as I'm concerned, feel free to
close this bug.
Comment 6 John Dennis 2008-01-10 17:01:06 EST
Thank you Ville for your extra effort in verifying this, a lot of folks would
not have taken the time. Your help is very much appreciated.
Comment 7 Ville Skyttä 2008-01-15 18:34:46 EST
No problem, thank yourself, that's the least I could do after seeing your
excellent effort to help in comment 4.

Note You need to log in before you can comment on or make changes to this bug.