Bug 376041 - Cannot check setroubleshoot service status as non-root
Summary: Cannot check setroubleshoot service status as non-root
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: setroubleshoot   
(Show other bugs)
Version: 8
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: John Dennis
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-11-11 15:28 UTC by Ville Skyttä
Modified: 2008-02-28 21:43 UTC (History)
0 users

Fixed In Version: setroubleshoot-2.0.2-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-09 17:42:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ville Skyttä 2007-11-11 15:28:51 UTC
$ /etc/init.d/setroubleshoot status
(nothing)

This is caused by a too early "test `id -u` = 0  || exit 4" in the init script.
 At least the status action should be allowed for non-root users, and for
actions that require root access, an error message should be emitted instead of
failing silently when run as non-root.

Comment 1 John Dennis 2007-11-12 15:53:22 UTC
Good point, will fix...

Comment 2 John Dennis 2008-01-09 17:42:37 UTC
fixed in setroubleshoot-2.0.2-1

Comment 3 Fedora Update System 2008-01-15 22:54:56 UTC
setroubleshoot-2.0.2-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update setroubleshoot'

Comment 4 Fedora Update System 2008-02-26 02:18:51 UTC
setroubleshoot-plugins-2.0.4-3.fc8,setroubleshoot-2.0.5-2.fc8 has been submitted as an update for Fedora 8

Comment 5 Fedora Update System 2008-02-28 21:43:02 UTC
setroubleshoot-plugins-2.0.4-3.fc8, setroubleshoot-2.0.5-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.