Bug 376111 - Java Problem with Azureus
Java Problem with Azureus
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: java-1.7.0-icedtea (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Thomas Fitzsimmons
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-11 11:18 EST by Rob Weijer
Modified: 2008-01-15 18:04 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-03 12:07:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error Log Java (35.15 KB, text/plain)
2007-11-11 11:18 EST, Rob Weijer
no flags Details
Java Error Report (43.98 KB, text/plain)
2007-11-22 11:07 EST, Rob Weijer
no flags Details
Third torrrent (14.18 KB, application/x-bittorrent)
2007-11-22 11:12 EST, Rob Weijer
no flags Details

  None (edit)
Description Rob Weijer 2007-11-11 11:18:50 EST
Description of problem:
After starting Azureus, within a minute Azureus shuts down.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Rob Weijer 2007-11-11 11:18:50 EST
Created attachment 254731 [details]
Error Log Java
Comment 2 Anthony Green 2007-11-11 16:16:03 EST
I'm moving this over to the Iced Tea queue.
Comment 3 Lillian Angel 2007-11-22 10:45:55 EST
I can't reproduce this problem with:
azureus 2.5.0.4-4.fc9
java-1.7.0-icedtea-1.7.0.0-0.20.b23.snapshot.fc9

Can you give me more information?
Comment 4 Rob Weijer 2007-11-22 11:07:12 EST
Created attachment 267061 [details]
Java Error Report

This is the latest Java Error Report I have...
Comment 5 Rob Weijer 2007-11-22 11:11:25 EST
I start with no torrents loaded.
When I put 1 torrent in my auto-import directory, everything goes fine. 
Azureus will import it normally. The second also import normally.
I almost realized that it wouldn't be a bug after all, the third time for the 
auto-import feature... yes, Azureus shuts down immediately with the Error 
Report in the attachment...
It could also be the torrent itself which cause the problem, so the other 
attachment is the third imported torrent...
Comment 6 Rob Weijer 2007-11-22 11:12:27 EST
Created attachment 267071 [details]
Third torrrent

torrent which shuts down Azureus
Comment 7 Lillian Angel 2007-11-22 11:43:27 EST
I don't think it is the torrent you attached, because it works fine for me.
Comment 8 Julian Sikorski 2007-11-22 14:08:06 EST
Sometimes must be wrong with Azureus' filesystem browsing ability. So far I have
found tow ways to bring it down with the fresh config. You either need to do
Open Torrents > Browse change the default location, go to Open Torrents > Add
files or go to Open Torrents > Add folder and also change the default location.
Comment 9 Dan Horák 2007-11-22 14:30:52 EST
(In reply to comment #8)
> Sometimes must be wrong with Azureus' filesystem browsing ability. So far I have
> found tow ways to bring it down with the fresh config. You either need to do
> Open Torrents > Browse change the default location, go to Open Torrents > Add
> files or go to Open Torrents > Add folder and also change the default location.

I have seen such crashes too, see #371521.

Original report is from an i386 machine, my bug is also from i386. On my x86_64
Azureus can be started, files can be browsed (but I have tested it only
lightly). Has anybody problems on non-i386 machine?
Comment 10 Lillian Angel 2007-11-30 10:12:15 EST
rpm -qa java-1.7.0-icedtea ? 

I can't reproduce this with java-1.7.0-icedtea-1.7.0.0-0.20.b23.snapshot.fc9 on
i386 or x86_64.
Comment 11 Julian Sikorski 2007-11-30 10:37:47 EST
Happens with both java-1.7.0-icedtea-1.7.0.0-0.19.b21.snapshot.fc8.x86_64 and
the rawhide version.
Comment 12 Lillian Angel 2007-11-30 10:41:22 EST
Ok thanks, I will keep testing it out.
Comment 13 Lillian Angel 2007-11-30 10:58:54 EST
Ah, this seems to be a regression between Sun's JDK 1.5 and 1.6. I am working on
a fix for IcedTea
Comment 14 Lillian Angel 2007-11-30 13:21:37 EST
Further testing shows this is a problem with Azureus, and it is fixed with
3.0.3.4. I will push for an update in rawhide.
Comment 15 Lillian Angel 2007-12-03 12:07:27 EST
Updated to azureus-3.0.3.4-1.fc9. 
Should be available tomorrow in rawhide.
Comment 16 Fedora Update System 2008-01-15 18:04:32 EST
azureus-3.0.3.4-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.