Bug 3763 - RH_6.0 "bootnet.img" IO and IRQ of DE203/4/5 undocumented
RH_6.0 "bootnet.img" IO and IRQ of DE203/4/5 undocumented
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-06-27 17:00 EDT by Nadim Ghaznavi
Modified: 2008-08-01 12:22 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nadim Ghaznavi 1999-06-27 17:00:34 EDT
According to the documentation in the source code for the:

        ewrk3.c : DE203/4/5 : Digital's EtherWORKS NIC

In order to use the driver code as a module (which is what
the RedHat 6.0 install program does), you must follow 8
steps:

....... (snip -nadim)
0) have a copy of the loadable modules code installed on
your system.
1) copy ewrk3.c from the  /linux/drivers/net directory to
your favourite temporary directory.
2) edit the  source code near  line 1898 to reflect  the I/O
address and IRQ you're using.
....... (snip -nadim)

Using Tom's Root/Boot Disk, I booted my new system.  I then
compiled the ewrk3.o module on a different workstation, and
moved it to my new system via floppy.  I could sucessfully
load the modules, and use that network interface (using
ping).  I found that I could sucessfully repeat this
process, but that (as per the documentation in the source
code) I had to recompile the module for the specific
hardware configuration I had (e.g. with line 1882 set to:

        0x260, 10,   /* I/O address, IRQ */

                -for IO set to 260hex, and IRQ set to 10).

Using this mechanism to test my hardware, and the driver, I
managed to get two DE205 cards working at the same time,
using two copies of the driver, with the appropriate
resource (IO address, and IRQ) hard coded into the module's
code.

I believe this will clearly demonstrate that the IO and IRQ
values compiled into the RedHat 6.0 EtherWorks (ewrk3.o)
module (on the RedHat 6.0 boot disk image bootnet.img) need
to be published to provide support for that NIC.
Comment 1 Jeff Johnson 1999-06-27 17:11:59 EDT
I'm changing the component to kernel because that's where drivers
are compiled.
Comment 2 Jay Turner 1999-06-28 08:49:59 EDT
This issue has been forwarded to a developer for further action.
Comment 3 Cristian Gafton 1999-07-02 17:21:59 EDT
/proc filesystem should be of help with this. Anyway,a ssigned to
dledford to see if there is anything we can do.
Comment 4 Nadim Ghaznavi 1999-07-05 22:10:59 EDT
If there's nothing to be done (which is lame, considering all that's
required is for someone with access to the source to check line 1882
of the ewrk3.c file, and publish the IO and IRQ), then the DE203/4/5
should be removed from the supported hardware list, since obviously
the driver is unusable without knowing what resources it's configured
to use.

Note You need to log in before you can comment on or make changes to this bug.