Bug 376331 - KDE logout doesn't work
KDE logout doesn't work
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-11 14:03 EST by Philip Ashmore
Modified: 2007-12-10 06:55 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-10 06:55:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Philip Ashmore 2007-11-11 14:03:14 EST
Description of problem:
KDE logout doesn't work

Version-Release number of selected component (if applicable):
KDE 3.5.8-7.fc8

How reproducible:
Every time I try it in this session! I also think I remember it happening with
an F8 test live image

Steps to Reproduce:
1. Try to log out.

Actual results:
You can't, either with the lock/logout applet or the K menu

Expected results:
You are presented with the logout dialog.

Additional info:
This was after entering several bug reports, interrupted by a break lasting
about an hour during which the screen was locked.
Comment 1 Rex Dieter 2007-11-11 15:23:38 EST
We issued a 0-day update to address a similar issue, knetworkmanger-0.2-0.7.fc8,
please update, and confirm whether or not that helps you.
Comment 2 David Kovalsky 2007-12-07 10:22:36 EST
I'm using kdebase-3.5.8-5.fc8 ATM with the latest & greatest updates updates
there are for F8.

I've also been experiencing this issue. As a temporary solution I had 
DESKTOP="KDE"
DISPLAYMANAGER="KDE"
in my /etc/syscondif/desktop file and everything worked as expected. Today I
tried removing the config file and everything seems to work correctly.
Comment 3 Rex Dieter 2007-12-07 10:29:52 EST
rpm -q knetworkmanager 
?
Comment 4 David Kovalsky 2007-12-07 11:10:11 EST
knetworkmanager-0.2-0.7.fc8

Please not that I'm not using (k)networkmanager at all.
Comment 5 Rex Dieter 2007-12-07 11:17:42 EST
If it's installed, it (nm-applet) still tries to run.  If you're not using it,
rpm -e knetworkmanager NetworkManger-gnome
and see if that helps.
Comment 6 David Kovalsky 2007-12-07 11:24:56 EST
I probably didn't phrase it right - it works for me, everything is fine and
working as expected. That's what I meant by 'Today I
tried removing the config file and everything seems to work correctly.' :-)

Comment 7 Rex Dieter 2007-12-07 12:07:46 EST
Do you have gdm installed?  If so, removing the config file means you're now
using gdm instead of kdm.
Comment 8 David Kovalsky 2007-12-07 12:12:49 EST
Yes, I do have gdm installed. It works with both kdm and gdm. 
Comment 9 Philip Ashmore 2007-12-10 01:20:59 EST
I've run yum update several times since I reported the problem.
It seems to have been corrected.
Comment 10 Rex Dieter 2007-12-10 06:55:46 EST
Thanks.

Note You need to log in before you can comment on or make changes to this bug.