Bug 376341 - audacity--1.3.2-16.fc8.x86_64.rpm is missing dependency for libexpat.so.0
audacity--1.3.2-16.fc8.x86_64.rpm is missing dependency for libexpat.so.0
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: audacity (Show other bugs)
8
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Gérard Milmeister
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-11 14:12 EST by Walkie
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-11 14:22:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Walkie 2007-11-11 14:12:10 EST
Description of problem:
after making yum install audacity when trying to run audacity it fails to run
with message
audacity: error while loading shared libraries: libexpat.so.0: cannot open
shared object file: No such file or directory

Version-Release number of selected component (if applicable):
audacity--1.3.2-16.fc8.x86_64.rpm

How reproducible:
can be easily reproduced

Steps to Reproduce:
1. #yum install audacity
2. $audacity
  
Actual results:
audacity: error while loading shared libraries: libexpat.so.0: cannot open
shared object file: No such file or directory

Expected results:
application start

Additional info:
this can be easily fixed by making
#yum install compat-expat1
reporting this bug only to make packager know of this problem to fix .spec file
for automatic downloading dependency when doing yum install audacity
Comment 1 Michael Schwendt 2007-11-11 14:22:34 EST
Please see package %changelog. We've rebuilt for the new expat
on Aug 29th:

  $ rpm -qpR audacity-1.3.2-16.fc8.x86_64.rpm|grep expat
  libexpat.so.1()(64bit)  

Where do you see any dependency on libexpat.so.0?
Comment 2 Walkie 2007-11-12 11:33:27 EST
Sorry for false alarm and thanks.
Now it works fine, but I want to describe the reason why this bug happends.
I used not clear installation of F8 but upgrade from F7. It upgrades packages
existing on DVD but stayed unupgraded packages from repository Everything. Some
of this packages needed for audacity stayed linked against libexpat.so.0 so the
situations happends which i was reported.
I should make yum update all to fix the situation. But it takes a long time to
complete on my internet connection. BTW after installing compat-expat1 audacity
fails to run with
*** glibc detected *** audacity: free(): invalid pointer: 0x0000000000d3d9c0 ***
and the long backtrace following
I decided to someway halfreport problems - the unclear run fail to wait until
yum update all finishes, and mistakenly clear missing dependency report. (there
was really unclear audacity or it's libs linked against libexpat.so.0)
The result of this situation:
1. yum update all must be made after upgrading from previous version after
configuring all repositories (or some stage must exists in installer during upgrade)
2. more research must be made before reporting the bug even if situations seems
clear
I'm writing this for people to have experience in such situations.

Note You need to log in before you can comment on or make changes to this bug.