Bug 37636 - gcc has problems compiling the kernel 2.4.3 with --march=k6
gcc has problems compiling the kernel 2.4.3 with --march=k6
Status: CLOSED DUPLICATE of bug 37637
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-25 12:45 EDT by Suchandra Thapa
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-25 12:46:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suchandra Thapa 2001-04-25 12:45:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.3 i586)


Giving the processor type as k6 compiles the kernel with a -march=k6 flag
which seems to cause the problem.  Switching processor type to pentium tsc
allows the kernel to compile cleanly..  This problem didn't show up when I
was using gcc-2.96-69 but is present in gcc-2.96-81.

Reproducible: Always
Steps to Reproduce:
1. make menuconfig and choose k6 as processor
2. try to compile kernel
3.
	

Actual Results:  gcc -D__KERNEL__ -I/usr/src/linux-2.4.3/include -Wall
-Wstrict-prototypes -O2 -fomit-frame-pointer -fno-strict-aliasing -pipe
-mpreferred-stack-boundary=2 -march=k6    -c -o setup.o setup.c
setup.c: In function `check_cx686_slop':
setup.c:1143: Internal error: Segmentation fault.
Please submit a full bug report.
Comment 1 Bill Nottingham 2001-04-25 13:03:26 EDT

*** This bug has been marked as a duplicate of 37637 ***

Note You need to log in before you can comment on or make changes to this bug.