Bug 37655 - Problems with ATI Rage Mobility & X
Summary: Problems with ATI Rage Mobility & X
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-25 18:17 UTC by David Mason
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-21 21:43:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X log (12.80 KB, text/plain)
2001-05-16 21:18 UTC, David Mason
no flags Details
XF86Config-4 (3.02 KB, text/plain)
2001-05-16 21:20 UTC, David Mason
no flags Details

Description David Mason 2001-04-25 18:17:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.2-2 i686; en-US; 0.8) Gecko/20010217


We're seeing some weird problems with the R128 driver from 7.1 
running on Dell C600 laptops:

One symptom the problem is that XSetWindowbackground(window, None)
is not working - instead of not clearing the background on exposes, 
the background is being cleared to black.

Another symptom is that every time that the background is set,
there is a flash to black.

It is very difficult to see this damned flash everyday!


Reproducible: Always
Steps to Reproduce:
1. Run 7.1 on a Dell C600 (perhaps other Rage Mobility based machines)
2.
3.

Comment 1 Mike A. Harris 2001-04-25 18:37:02 UTC
What happened to 2 & 3?  ;o)

Is this a Mobility M3 or M4?  Can you attach X server log from after the
weirdness happens, and also a copy of your config?  I do not have a laptop
to test with, but I have an M3 engineering sample.  If it is an M4, does
anyone around there have an M3 they can reproduce it on?  I have an M4
as well but can't use it (AGP 4x only).

Fire me any other info you think might help also.  TNX

Comment 2 David Mason 2001-04-25 19:11:41 UTC
uh... I don't know....

$scanpci

pci bus 0x1 cardnum 0x00 function 0x0000: vendor 0x1002 device 0x4c46
 ATI Rage 128 Mobility LF

Comment 3 David Mason 2001-04-25 19:32:41 UTC
ooh - ooh!

ATI Technologies Inc Rage Mobility M3 AGP 2x (rev 02)


Comment 4 David Mason 2001-05-14 18:15:20 UTC
If I run the X server in 24bit mode there is no more flicker! I am saved! No
more seizures! That should narrow the problem down to an even smaller code set
too :)

Comment 5 Mike A. Harris 2001-05-15 08:57:33 UTC
If you have DRI enabled, divide your RAM by 6.  That is approximately how
much RAM is available for one screen.  DRI needs lots of RAM + RAM for textures
and pixmaps, etc..

Future releases of Xconfigurator at some point will have a checkbox to enable
or disable DRI, and will calculate the maximum resolution available with DRI
enabled.

Comment 6 Mike A. Harris 2001-05-15 08:58:08 UTC
Oh, I almost forgot, I need your config file and X logs still...

Comment 7 David Mason 2001-05-16 21:18:13 UTC
Created attachment 18670 [details]
X log

Comment 8 David Mason 2001-05-16 21:20:35 UTC
Created attachment 18671 [details]
XF86Config-4

Comment 9 Mike A. Harris 2002-12-21 21:43:55 UTC
This problem has been fixed for a while now, and should not be present in
the current release (8.0) of Red Hat Linux.  I've tested a sample board that
ATI has provided, and it works ok.




Note You need to log in before you can comment on or make changes to this bug.