Bug 376561 - Yum does not see packages of other architectures
Yum does not see packages of other architectures
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
8
All Linux
high Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-11 16:29 EST by Lubomir Kundrak
Modified: 2014-01-21 18:00 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-11 19:09:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lubomir Kundrak 2007-11-11 16:29:40 EST
Description of problem:

On my system with i686 installation of Fedora 8 I can't force yum to see x86_64
packages no matter how hard I try.

Version-Release number of selected component (if applicable):

yum-3.2.7-1.fc8

How reproducible:

Always

Steps to Reproduce:

(In i686 installation)

0. # yum clean all
1. # mv /etc/yum.repos.d{,.away}
2. # mv /etc/yum.conf{,.away}
3. # cat >/etc/yum.conf <<EOF
> [main]
> exactarch=0
> plugins=0
> 
> [fedora]
> name=fedora
>
baseurl=http://download.fedora.redhat.com/pub/fedora/linux/releases/8/Everything/x86_64/os/
> enabled=1
> EOF
# yum clean all
  
Actual results:

# yum list |grep x86_64
# yum install glibc.x86_64
Setting up Install Process
Parsing package install arguments
No package glibc.x86_64 available.
Nothing to do
#

Expected results:

Being able to list/install the x86_64 packages

Additional info:

Pardon me if this is not a bug, but my misunderstanding of how yum should work.
Please suggest an alternative way to force a package of a different architecture
with its dependencies into my system. Thanks!
Comment 1 James Antill 2007-11-11 19:09:20 EST
 It doesn't work that way around, x86_64 can install i686 but not the other way
around (that way around it just thinks it's an i686 machine).
Comment 2 Lubomir Kundrak 2007-11-12 03:44:20 EST
Thanks for the clarification, James! In that case I am wordering whether I can
reopen this bug as a enhancement request?

It still makes sense to be able to work with packages of other architectures.
Probably just list them, or inspect the metadata if not install. And it might be
argued, that yum can not know binaries of which architectures are actually
executable on the machine (apart from different kernels it might be due to
qemu-arm, or whichever qemu hooked on binfmt_misc, etc).
Comment 3 Seth Vidal 2007-11-12 10:02:11 EST
If you want to do special-case work like that then you need to use the yum api
in a program to tell it to do so.

It's not a bug in yum that the capability is not exposed on the cli.

Note You need to log in before you can comment on or make changes to this bug.