Bug 376651 - http upgrade fails - unable to fetch Fedora-8-comps.xml
http upgrade fails - unable to fetch Fedora-8-comps.xml
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-11-11 18:20 EST by Joe Bayes
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-11-19 15:09:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Joe Bayes 2007-11-11 18:20:34 EST
Description of problem:
I am upgrading from f7 to f8 via ftp or http (I tried both) from a local Win2000
box. I have the isolinux directory on a local drive, and am booting from there.

I get as far as telling anaconda to update my boot loader, click next, and it
pops up a window that says, "Unable to read group information from repositories.
This is a problem with the generation of your install tree."

When I switch to the console window, I see "WARNING: Try 1/10 for". The above is repeated 9 more
times. Then it says "Failed to get". 

Version-Release number of selected component (if applicable):
Whatever ships with Fedora 8.

How reproducible:

Steps to Reproduce:
1. Boot from the isolinux directory off a local HD.
2. Tell anaconda to upgrade a previous linux install, on /dev/vg0/root.
3. Follow instructions for a ftp or http install. (host=, directory=/)
Actual results:
Above pop-up comes up.

Expected results:
Install Fedora 8. 

Or, give me a more useful error message, perhaps one that explains why it can
fetch /images/stage2.img, but it can't fetch /./repodata/Fedora-8-comps.xml.

Additional info:
Anaconda retrieves the stage2 data just fine, so I don't think I entered the ip
address wrong. I wonder if perhaps the extra "./" in the url is confusing
something somewhere. I did not put that "./" in the directory name. 

I tried fetching using wget, and
that worked just fine. I also tried fetching with wget, and that worked just fine too.
Comment 1 Jeremy Katz 2007-11-12 14:27:47 EST
Does the sha1sum of the comps file in the repodata dir match the sha1sum in the
Comment 2 Joe Bayes 2007-11-13 18:35:01 EST
Erm. No, it doesn't. Thanks.

I blame the Windows machine. (Always a safe bet.) The copy I initially
downloaded is fine. 

I suggest that the error message be changed from, "Failed to get" to "Fedora-8-comps.xml does
not match expected sha1sum" or "repodata/Fedora-8-comps.xml appears to be
corrupt" or something like that. The former implies that there is a problem with
the data transfer, which there is not. 
Comment 3 Chris Lumens 2007-11-19 15:09:28 EST
I don't believe we have the information to make a distinction between failure to
get the file and getting a corrupt file.  I've added to the error message
indicating that the file may also be corrupt.
Comment 4 Joe Bayes 2007-11-21 13:13:51 EST
Thanks for doing that. The misleading error message cost me several hours' work;
I'd hate to see it go unfixed. 

Note You need to log in before you can comment on or make changes to this bug.