Bug 376701 - vpnc 0.4.0 connects but doesn't pass traffic
vpnc 0.4.0 connects but doesn't pass traffic
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: vpnc (Show other bugs)
7
All Linux
low Severity high
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-11 19:01 EST by Russell Harrison
Modified: 2008-04-04 13:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-04 13:31:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Russell Harrison 2007-11-11 19:01:43 EST
Description of problem:
When I connect using vpnc 0.4 in F7 it seems to connect fine but I can only send
any sort of network traffic to routes that don't pass through the tunnel. 
Anything I attempt to send across the tunnel just times out.

Version-Release number of selected component (if applicable):
vpnc-0:0.4.0-2.fc7.i386

How reproducible:
Every time

Actual results:
Successful connection, and unable to send traffic across tun0

Expected results:
functional vpn tunnel

Additional info:

Since I noticed that NetworkManager-vpnc depended on vpnc > 0.3 I grabbed the
srpm from FC6 and recompiled it for F7.  It works like a champ.
Comment 1 Tomas Mraz 2007-11-12 03:42:39 EST
Can you try recompiling 0.5.1 from F8?
Comment 2 Russell Harrison 2007-11-12 10:44:19 EST
It also has the same problem.  I haven't gotten around to cloning this bug for
F8 but I've already confirmed it as not working there either.
Comment 3 Tomas Mraz 2007-11-12 10:53:30 EST
You should probably try to talk with upstream developers on the
https://lists.unix-ag.uni-kl.de/mailman/listinfo/vpnc-devel mailing list.

Note You need to log in before you can comment on or make changes to this bug.