Bug 37671 - RFE: gforth won't compile with gcc-2.96
RFE: gforth won't compile with gcc-2.96
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: gcc (Show other bugs)
1.0
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-25 15:09 EDT by Jeff Johnson
Modified: 2007-03-26 23:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-26 17:47:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeff Johnson 2001-04-25 15:09:08 EDT
This is just a FYI, and is really a gforth, not a gcc problem.

However, since I've just dropped gforth compiled with egcs
into powertools-7.2, I figgered I'd report the problem.

Nuke the package in powertools if you want <shrug>
Comment 1 Need Real Name 2001-05-06 02:16:00 EDT
This bug is probably due to gcc-2.96 producing incorrect code (guess based on
experience with similar symptoms in other settings).
Comment 2 Jakub Jelinek 2001-05-07 07:54:58 EDT
Yeah, engine() couldn't be shorter...
So far I've found one GCSE bug which caused engine-ditc.o to be miscompiled.
With this fixed, there is some other bug which causes engine.o to be miscompiled
with -fomit-frame-pointer (taking this one out fixes it).
I'll dig some more.
Comment 3 Need Real Name 2001-12-13 18:49:34 EST
I have now tested this a little more and found that Gforts works with
gcc-2.96 on Intel if it is configured with --enable-force-reg.  I
found that I get a good result (correct and fast code) with gcc
version 2.96 20000731 (Red Hat Linux 7.1 2.96-81) by configuring in
the following way:

CC="gcc -fno-gcse" ./configure --enable-force-reg --enable-indirect-threaded

I will look into the generated code for the crashing versions soon.
Comment 4 Jeff Law 2003-02-26 17:47:23 EST
The compiler included in Red Hat Linux 7.1 and later versions of Red Hat Linux
compiles gforth-5.0 correctly.  The errata compiler for Red Hat Linux 7.0 
(gcc-2.96-85) also compiles gforth-5.0 correctly.

Note You need to log in before you can comment on or make changes to this bug.