Bug 37693 - Kernel Panics Early in Installation
Kernel Panics Early in Installation
Status: CLOSED DUPLICATE of bug 36940
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-25 17:32 EDT by John Zaloudek
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:47:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Zaloudek 2001-04-25 17:32:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)


When Installing 7.1 on a compaq proliant 2500 (Bios rev E24(12/01/99) ) 
with a compaq SMART-2/P Raid Array Controller (rev C, v1.94)and 544M ram, 
the kernel panics before any options come up.  If it is of any help, if I 
type 
> linux mem=544 dd
the panic happens before it prompts for the driver disk ...  

Reproducible: Always
Steps to Reproduce:
1. at the boot prompt type linux mem=544M
	

Actual Results:  (first line for context)
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0
VFS: Cannot open root device "" or 08:41
Please append a correct "root=" boot option
Kernel panic: VFS: Unable to mount root fs on 08:41

Expected Results:  install continues

-the mem= setting is necessary as it doesn't recognize enough of the 
available memory to go through the install, although, without the setting 
it looks like the install gets further along (blue background with red 
error box, still not really into the install)
-the machine is dual PPro 200
-it happens with smaller mem= settings 
-it happens booting from atapi cd or from floppy
-the system currently runs redhat 7.0 smoothly
-I pulled out the array controller and it gives the same error for 
attempted install
-the system also has an ide hard drive
Comment 1 Brent Fox 2001-04-25 17:53:51 EDT
Sounds like this is either a kernel or a syslinux problem.  Changing component
to the kernel.  We've started to see a few of these.
Comment 2 Arjan van de Ven 2001-04-26 04:52:35 EDT
I've installed Linux once on such a machine. The trick is to get the bios 
right. Could you try appending "noapic" as 2nd option to the mem= line ?
eg
mem=543 noapic

(hint: always go at least 1Mb less than actual memory, as the bios uses about
1Mb)
Comment 3 John Zaloudek 2001-04-27 14:18:51 EDT
I attempted with both of the following; neither worked
mem=500 noapic
mem=500 noapic nosmp
Comment 4 Alan Cox 2003-06-09 13:18:48 EDT

*** This bug has been marked as a duplicate of 36940 ***
Comment 5 Red Hat Bugzilla 2006-02-21 13:47:58 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.