Bug 37699 - RFE: Posix ACL patch applied in default kernel
RFE: Posix ACL patch applied in default kernel
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-25 18:07 EDT by Kervin Pierre
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-27 05:26:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kervin Pierre 2001-04-25 18:07:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i686)


We are looking into using ACLs in our current setup ( comprising of
Solaris,WinNT,IRIX and Linux)  Linux is the only OS we support that does
not natively have support for ACLs ( due to support reasons we can not
recompile the kernel ).

ACLs are sorely needed but Linux is preventing this.  It would be very
helpful if Redhat came with the ACL patch included the kernel.  Or maybe
have a kernel+ACL.rpm on the CD

Reproducible: Always
Steps to Reproduce:
1.?
2.
3.
Comment 1 Daniel Roesen 2001-04-27 04:27:39 EDT
becomes especially interesting in the light of Samba 2.2.0 which supports NT
ACLs on ACL-enabled Linux systems...
Comment 2 Arjan van de Ven 2001-04-27 05:26:37 EDT
"the" ACL patch --> there are several ACL patches in existance.
all need to change exported kernel interfaces and on-disk structures of
filesystems. This makes it nearly impossible to merge such a patch until
the it is clear which ACL is going to be used in future Linux kernels....

Note You need to log in before you can comment on or make changes to this bug.