Bug 377051 - Miro-0.9.9.9-1.fc8 rpm requires firefox 2.0.0.9 (which does not exist in fedora 8 repo)
Miro-0.9.9.9-1.fc8 rpm requires firefox 2.0.0.9 (which does not exist in fedo...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Miro (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Alex Lancaster
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-11 23:24 EST by Jack Deslippe
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version: Miro-0.9.9.9-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-16 01:36:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jack Deslippe 2007-11-11 23:24:45 EST
Description of problem:
The version of miro now in the updates repo (Miro-0.9.9.9.1-1.fc7.i386.rpm)
seems to require gecko-libs = 1.8.1.9 which I think is part of firefox 2.0.0.9.
 Thus yum install Miro on fedora 8!

Version-Release number of selected component (if applicable):
0.9.9.9.1

How reproducible:

Try to yum install Miro

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Alex Lancaster 2007-11-12 02:34:49 EST
Yes, it's a mess, basically firefox's fault.  A new Miro was rebuilt against the
new firefox and pushed to make sure the update for firefox 2.0.0.9 worked out of
the box (i.e. that Miro would also smoothly update).  Unfortunately the firefox
maintainers decided to pull the firefox update at the last moment and didn't
also keep back the updated dependencies that were rebuilt for it (like Miro).

Of course this all happened the day after F-8 was released, and then came the
weekend, and no pushes seem to happen on the weekend because only one person can
actually do the push.   To make matters worse, on F-8 the firefox update *was*
pushed but the Miro update wasn't.  

Basically, firefox updates really screw up the system and the firefox
maintainers don't really communicate exactly what is going to happen or
co-ordinate with downstream package managers properly.  So apologies for that
but I can't do anything about it until new updates are pushed.

Meantime, the best I can suggest is simply disable the updates repo for when
installing Miro from the update until the new firefox is pushed (hopefully
Monday), e.g.:

yum --disablerepo=updates install Miro

and then:

yum --exclude=Miro updates

for subsequent updates.

Hopefully this will all be sorted out soon.
Comment 2 Mike A. Harris 2007-11-12 05:59:54 EST
Bug confirmed.

pts/0 root@hammer:~# yum update
Loading "protectbase" plugin
Loading "protect-packages" plugin
Loading "changelog" plugin
Loading "fastestmirror" plugin
Loading mirror speeds from cached hostfile
0 packages excluded due to repository protections
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package Miro.x86_64 0:0.9.9.9-1.fc8 set to be updated
--> Processing Dependency: gecko-libs = 1.8.1.9 for package: Miro
--> Finished Dependency Resolution
Error: Missing Dependency: gecko-libs = 1.8.1.9 is needed by package Miro
Comment 3 Luis Villa 2007-11-13 08:19:04 EST
Isn't this exactly what updates-testing is supposed to prevent?
Comment 4 Alex Lancaster 2007-11-13 14:09:11 EST
(In reply to comment #3)
> Isn't this exactly what updates-testing is supposed to prevent?

It is usually, but firefox is normally pushed direct to stable (because they are
security updates) and therefore the deps have to be pushed to stable ASAP as
well, to avoid breakage.  However, in this particular case, the firefox update
was pulled at the last second, but the dependent packages weren't mainly because
the firefox maintainers didn't keep track of the dependent packages and hold
them back from going to stable too.
Comment 5 Steve Fox 2007-11-15 21:55:57 EST
I was finally able to update Miro today so this particular bug can be closed.
However I will next open another bug due to some crap with DBus and Python
hating each other. Thanks for fixing the dependency issue.
Comment 6 Jack Deslippe 2007-11-16 03:01:42 EST
Yep, thanks for the resolution of this bug/

Note You need to log in before you can comment on or make changes to this bug.