Bug 377171 - Klipper has wrong WM_CLASS for firefox
Klipper has wrong WM_CLASS for firefox
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Lukáš Tinkl
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-12 01:45 EST by Joe Rozner
Modified: 2015-07-13 13:36 EDT (History)
2 users (show)

See Also:
Fixed In Version: 3.5.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-25 08:02:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Rozner 2007-11-12 01:45:42 EST
Description of problem:
The WM_CLASS for Firefox and possibly other applications are entered incorrectly
or missing from Klipper causing it not to ignore applications which are on the list.

How reproducible:
It is reproducible on any system with Klipper events enabled.

Steps to Reproduce:
1. Highlight the address in the address bar in firefox
  
Actual results:
A dialog will pop up asking for the action.

Expected results:
Klipper should ignore this application.

Additional info:
It's a simple fix at least for Firefox that just needs to be added into the
package. The WM_CLASS for Firefox is "gecko" and not the various other names
listed. If this issues exists for Firefox it may also exist for other
applications listed.
Comment 1 Lukáš Tinkl 2007-12-17 06:52:37 EST
Devel (kde4) doesn't contain the bug, will fix for F7 and F8
Comment 2 Lukáš Tinkl 2007-12-18 05:22:45 EST
Fixed
Comment 3 Fedora Update System 2007-12-20 14:50:08 EST
kdebase-3.5.8-25.fc7, kdelibs-3.5.8-19.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdebase kdelibs'
Comment 4 Fedora Update System 2007-12-20 15:16:39 EST
kdebase-3.5.8-25.fc8, kdelibs-3.5.8-19.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdebase kdelibs'
Comment 5 Fedora Update System 2008-01-15 17:54:17 EST
kdebase-3.5.8-30.fc7, kdelibs-3.5.8-19.fc7, gtk-qt-engine-0.8-2.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdebase kdelibs gtk-qt-engine'
Comment 6 Fedora Update System 2008-01-15 18:11:25 EST
gtk-qt-engine-0.8-2.fc8, kdelibs-3.5.8-19.fc8, kdebase-3.5.8-30.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gtk-qt-engine kdelibs kdebase'
Comment 7 Fedora Update System 2008-01-18 19:01:09 EST
kdebase-3.5.8-30.fc7.1, kdelibs-3.5.8-19.fc7, gtk-qt-engine-0.8-2.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdebase kdelibs gtk-qt-engine'
Comment 8 Fedora Update System 2008-01-27 02:10:15 EST
kdebase-3.5.8-30.fc7.1, kdelibs-3.5.8-19.fc7, gtk-qt-engine-0.8-2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2008-01-27 02:25:28 EST
kdebase-3.5.8-30.fc8, kdelibs-3.5.8-19.fc8, gtk-qt-engine-0.8-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Joe Rozner 2008-01-28 20:43:05 EST
The correct WM_CLASS was still not added. I see "geko" which may or may not have
been there originally, but "gecko" is still missing.
Comment 11 Lukáš Tinkl 2008-02-25 07:42:29 EST
Not nice, somebody removed the patch from a recent update... 
(kdebase-3.5.8-klipper-firefox.patch)
Comment 12 Lukáš Tinkl 2008-02-25 08:02:18 EST
I see, it's been fixed upstream so it's not needed anymore with the update to 
3.5.9, closing

Note You need to log in before you can comment on or make changes to this bug.