Bug 377321 - Broken upgrade path: kdelibs3 >= 3.5.8 is needed by package koffice-libs
Summary: Broken upgrade path: kdelibs3 >= 3.5.8 is needed by package koffice-libs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: koffice
Version: 7
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Andreas Bierfert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-11-12 09:33 UTC by Robert Scheck
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version: 3.5.8-7.fc7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-13 00:05:08 UTC


Attachments (Terms of Use)

Description Robert Scheck 2007-11-12 09:33:42 UTC
Description of problem:
[...]
koffice-libs.i386                        1.6.3-9.fc7            installed
kdelibs.i386                             6:3.5.7-22.fc7         installed
Skipping security plugin, no data
--> Running transaction check
---> Package koffice-karbon.i386 0:1.6.3-13.fc7 set to be updated
---> Package koffice-kspread.i386 0:1.6.3-13.fc7 set to be updated
---> Package koffice-libs.i386 0:1.6.3-13.fc7 set to be updated
--> Processing Dependency: kdelibs3 >= 3.5.8 for package: koffice-libs
---> Package koffice-kchart.i386 0:1.6.3-13.fc7 set to be updated
---> Package koffice-filters.i386 0:1.6.3-13.fc7 set to be updated
---> Package koffice-suite.i386 0:1.6.3-13.fc7 set to be updated
---> Package koffice-kpresenter.i386 0:1.6.3-13.fc7 set to be updated
---> Package koffice-kformula.i386 0:1.6.3-13.fc7 set to be updated
---> Package koffice-kplato.i386 0:1.6.3-13.fc7 set to be updated
---> Package koffice-kexi.i386 0:1.6.3-13.fc7 set to be updated
---> Package koffice-kword.i386 0:1.6.3-13.fc7 set to be updated
---> Package koffice-core.i386 0:1.6.3-13.fc7 set to be updated
---> Package koffice-krita.i386 0:1.6.3-13.fc7 set to be updated
---> Package koffice-kivio.i386 0:1.6.3-13.fc7 set to be updated
---> Package koffice-kugar.i386 0:1.6.3-13.fc7 set to be updated
---> Package koffice-kexi-driver-pgsql.i386 0:1.6.3-13.fc7 set to be updated
---> Package koffice-kexi-driver-mysql.i386 0:1.6.3-13.fc7 set to be updated
--> Finished Dependency Resolution
Error: Missing Dependency: kdelibs3 >= 3.5.8 is needed by package koffice-libs

Version-Release number of selected component (if applicable):
koffice-libs-1.6.3-9.fc7
kdelibs-3.5.7-22.fc7

How reproducible:
Everytime, see above.
  
Actual results:
Broken upgrade path: kdelibs3 >= 3.5.8 is needed by package koffice-libs

Expected results:
Working upgrade path by fixing it... ;-)

Comment 1 Rex Dieter 2007-11-12 12:35:46 UTC
kde-3.5.8 update is currently only in updates-testing,
https://admin.fedoraproject.org/updates/F7/FEDORA-2007-2985

I've marked it to be pushed to stable, which will hopefully happen asap.

Comment 2 Fedora Update System 2007-11-13 00:05:05 UTC
kdegraphics-3.5.8-7.fc7, kdebindings-3.5.8-1.fc7, kdeutils-3.5.8-2.fc7, kde-i18n-3.5.8-1.fc7, kdewebdev-3.5.8-3.fc7, kdenetwork-3.5.8-6.fc7, kdegames-3.5.8-3.fc7, kdeadmin-3.5.8-1.fc7, kdeaccessibility-3.5.8-2.fc7, kdelibs-3.5.8-7.fc7, kdepim-3.5.8-5.svn20071013.ent.fc7, kdetoys-3.5.8-1.fc7, kdeartwork-3.5.8-1.fc7, kdevelop-3.5.0-4.fc7, kdesdk-3.5.8-2.fc7, kdemultimedia-3.5.8-8.fc7, kdeedu-3.5.8-2.fc7, kdeaddons-3.5.8-2.fc7, kdebase-3.5.8-3.fc7, arts-1.5.8-4.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.