Bug 377391 - Package review: perl-MLDBM
Package review: perl-MLDBM
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jason Tibbitts
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-12 04:58 EST by Marcela Mašláňová
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.01-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 19:43:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
tibbs: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Marcela Mašláňová 2007-11-12 04:58:57 EST
Description of problem:
The review of this package wasn't done and now is needed for branching to EPEL.
Comment 1 Parag AN(पराग) 2007-11-12 05:11:08 EST
Strange howcome this got missed from Merge-Review tickets?
Comment 2 Jason Tibbitts 2007-11-14 21:12:44 EST
This isn't a merge review; this is one of the packages that came in with the
original import of the pre-extras fedora.us packages.  It is possible that an
initial review exists either in that old (and long since dead) bugzilla or in
some old mailing list, although an IRC chat with an ancient history archivist
didn't turn up any leads.

So I'll do a quick review, just to make it official....
Comment 3 Jason Tibbitts 2007-11-15 19:43:04 EST
* source files match upstream:
   e83550629724c9b2e4ddd3fe777c8240d44f62e37338361a59ebec5f8e8e3893  
   MLDBM-2.01.tar.gz
* package meets naming and versioning guidelines.
* specfile is properly named, is cleanly written and uses macros consistently.
* summary is OK.
* description is OK.
* dist tag is present.
* build root is OK.
* license field matches the actual license.
* license is open source-compatible.
* license text not included upstream.
* latest version is being packaged.
* BuildRequires are proper.
* %clean is present.
* package builds in mock (rawhide, x86_64).
* package installs properly
* rpmlint is silent.
* final provides and requires are sane:
   perl(MLDBM) = 2.01
   perl(MLDBM::Serializer)
   perl(MLDBM::Serializer::Data::Dumper)
   perl(MLDBM::Serializer::FreezeThaw)
   perl(MLDBM::Serializer::Storable)
   perl-MLDBM = 2.01-5.fc9.1
  =
   perl >= 0:5.004
   perl(:MODULE_COMPAT_5.8.8)
   perl(Carp)
   perl(Data::Dumper)
   perl(FreezeThaw)
   perl(Storable)
   perl(Tie::Hash)
   perl(strict)
   perl(vars)

* %check is present and all tests pass:
   All tests successful.
   Files=4, Tests=22,  0 wallclock secs ( 0.09 cusr +  0.05 csys =  0.14 CPU)
  (There is one warning, which looks to be a bug in the test suite)
* owns the directories it creates.
* doesn't own any directories it shouldn't.
* no duplicates in %files.
* file permissions are appropriate.
* no scriptlets present.
* code, not content.
* documentation is small, so no -docs subpackage is necessary.
* %docs are not necessary for the proper functioning of the package.

APPROVED

And since this is already in the repo in this state, I'll go ahead and close
this ticket.  If you need to make a branching request, just reply and set the
fedora-cvs flag without reopening.

Note You need to log in before you can comment on or make changes to this bug.