Bug 377461 - Unsuccessfull update from FC-6 to F-8
Unsuccessfull update from FC-6 to F-8
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-12 05:37 EST by Marcela Mašláňová
Modified: 2014-01-21 18:00 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-06 23:07:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum log file (62.28 KB, text/plain)
2007-11-12 13:17 EST, Marcela Mašláňová
no flags Details

  None (edit)
Description Marcela Mašláňová 2007-11-12 05:37:22 EST
Description of problem:
I went through upgrade as it is on fedoraproject. Many of fc6 packages weren't
uninstall. I had xorg-* packages doubled so X wasn't run. I have to manually
uninstall some of them and reinstall xorg-*. 
I'm not sure if it's problem of rpm, yum or something else. If you are
interested I could attached log files. 

Expected results:
Yum remove old packages and install new.
Comment 1 Seth Vidal 2007-11-12 10:03:21 EST
log files would be welcome. but it is likely that they weren't removed due to
rpm scriptlet error

 Also run:

package-cleanup --cleandupes
Comment 2 Marcela Mašláňová 2007-11-12 13:17:46 EST
Created attachment 255531 [details]
yum log file
Comment 3 Marcela Mašláňová 2007-11-12 13:30:51 EST
I did:
1/ yum clean all
2/ rpm -Uhv ftp://my mirror
3/ yum install yum-utils; package-cleanup --orphans
4/ yum upgrade
Now I know the problem could be in rpm and yum, because on the computer were
both version and somewhere in the update my usb keyboard stop working, also
screen go off. After restart I had only console, where I found out that here are
dozens of dupes and I removed rpm and yum manually (fc6). Then I clean the rest
with package-cleanup --orphans. I know that my update wasn't correct in all
parts but I thought that here's some problem with removing old packages with yum
(or rpm bug).
Comment 4 Seth Vidal 2007-12-06 23:07:14 EST
not sure what else we can do in this situation (other than fix the scriptlet bugs)

I'm going to close this b/c there's not much to fix in yum. for the leftover
packages file bugs about the scriptlet errors in bugzilla for each package.

thanks

Note You need to log in before you can comment on or make changes to this bug.