Bug 378091 - Condor User/Group Request
Condor User/Group Request
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: setup (Show other bugs)
5.1
All Linux
high Severity low
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks: 458296
  Show dependency treegraph
 
Reported: 2007-11-12 11:01 EST by Matthew Farrellee
Modified: 2015-03-04 20:19 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-27 04:17:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Farrellee 2007-11-12 11:01:20 EST
I need a user and group created for a new Condor package, a batch processing
system. The user and group name should be "condor" with a home directory of
/var/lib/condor. It is used to own all Condor daemons and files as well as run
user specified jobs. The Condor package is currently creating the account with:

%pre
getent group condor >/dev/null || groupadd -r condor
getent passwd condor >/dev/null || \
  useradd -r -m -g condor -d %_var/lib/condor -s /sbin/nologin \
    -c "Owner of Condor Daemons" condor
exit 0
Comment 2 RHEL Product and Program Management 2007-12-03 15:47:31 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release.  This request will
be reviewed for a future Red Hat Enterprise Linux release.
Comment 10 Jeff Needle 2008-08-07 10:43:34 EDT
Since we check for the existence of the account and create it if it's not there, no big deal.  We'll just use the proper UID/GID as long as there's a guarantee that when it eventually gets into RHEL, the UID/GID will be 64:64.
Comment 11 Phil Knirsch 2008-08-07 10:56:20 EDT
Ok, then it shouldn't be a problem as i can guarantee that as soon as a new setup package lands in RHEL-5 it will contain that pair of uid/gid for condor. :)

Read ya, Phil
Comment 15 errata-xmlrpc 2008-08-27 04:17:25 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2008-0838.html

Note You need to log in before you can comment on or make changes to this bug.