Bug 37813 - play reports: sox: Invalid audio buffer size 0 for esssolo1
Summary: play reports: sox: Invalid audio buffer size 0 for esssolo1
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-26 13:53 UTC by Hugh Bragg
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-22 08:47:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Hugh Bragg 2001-04-26 13:53:30 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.19-6.2.1 i686; Nav)


I have compiled esssolo1 as both module and kernel with the same result.
My modules.conf file reads:
alias sound-slot-0 esssolo1
options esssolo1 io=0x220,0x330,0x388 irq=5 dma=1,5
options sound dmabuf=1

It makes no difference if I use dmabuffer=0 either.
There are no compile problems and the board used to work with kernel-2.2.16
but did not work for kernel 2.2.17 and 2.2.19

/var/log/messages reports nothing but snconfig causes the first console to
report that soundblaster8 went missing.
The cdrom play fine.

Reproducible: Always
Steps to Reproduce:
1.compile esssolo1
2.reboot
3.play a sound file
	

Actual Results:  Error message:
sox: Invalid audio buffer size 0

Expected Results:  music

I have the same problem at home with my ESS1680 (I think) model

Comment 1 Hugh Bragg 2001-05-22 08:47:47 UTC
Solved this one by deleting the /dev/dsp and /dev/audio devices.
Apparently when I upgraded from 2.2.16 to 2.2.19 the device was broken.
The solution appeared one day when /dev/dsp had grown to about 60Mb on my root
fs.
I don't know if this is reproducible, but it is a nasty bug if it destroys
devices.

Comment 2 Arjan van de Ven 2001-05-22 09:00:08 UTC
It's nasty all right.
I've NO idea what could cause this though.




Note You need to log in before you can comment on or make changes to this bug.