Bug 37831 - Services such as ftp and telnet are not enabled even when you tell it to allow them through the firewall
Services such as ftp and telnet are not enabled even when you tell it to allo...
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.1
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-26 10:49 EDT by IBM Bug Proxy
Modified: 2007-04-18 12:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-27 11:44:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2001-04-26 10:49:43 EDT
This is a minor, but annoying defect on the RH7.1 GA release.  During
install, I
reached the questions about firewall setup and told it to allow access to
services telnet and ftp.  When I booted up after the install, I couldn't
get to
them.  I looked at the config files under /etc/xinit.d and the config files
had
a comment that said they were enabled by default, but they were actually
disabled.  Workaround is to 'chkconfig telnet on' to turn telnet on, etc. 
I
know that the firewall/ipchains setup is independant of xinitd, but
wouldn't it
stand to reason that if you want to allow access to those ports, then you
want
the service started?  Even still, the default behaviour is not consistant
with
the comments in the config files.
Comment 1 Brent Fox 2001-04-26 14:47:12 EDT
What security level did you pick?
Comment 2 IBM Bug Proxy 2001-04-27 11:23:38 EDT
 Choices were High, Medium, and No Firewall.  The default was Medium and that's
 what I picked.
Comment 3 Brent Fox 2001-04-27 11:37:32 EDT
Yes, you are right.  The config file comments need to be changed.  The default
behavior is supposed to be off.

Trond, can you fix the config files?  This is not an anaconda problem.
Comment 4 Trond Eivind Glomsrxd 2001-04-27 11:44:24 EDT
This is the way the service config files are supposed to be by default.

If you want to change them on the basis of firewall configuration, do it in
anaconda - the default is not changing.

Comment 5 Michael Fulbright 2001-05-04 11:39:50 EDT
The firewall screen is intended to configure the firewall, not the services
which are running on the system.

The ntsysv command can be used to enable and disable services once the system is
installed.

Note You need to log in before you can comment on or make changes to this bug.