Bug 378371 - totem-xine crashes on PPC(PS3) with pulseaudio error
totem-xine crashes on PPC(PS3) with pulseaudio error
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
8
powerpc Linux
low Severity low
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-12 12:39 EST by Jason
Modified: 2007-12-09 19:08 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-09 19:08:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason 2007-11-12 12:39:19 EST
Description of problem:
totem-xine (from livna repository) crashes with the error below when run on F8/
PS3. VLC will play, however there is no audio output. Confirmed that audio is 
working on F8/PS3 with soundcard detection program, rdesktop with redirected 
audio, and rhythmbox playing mp3's.

*** PULSEAUDIO: Unable to create stream.
totem: pcm_pulse.c:115: pulse_stop: Assertion `pcm->stream' failed.

This same setup works on i386; both xine and vlc work as expected.

Version-Release number of selected component (if applicable):
totem-xine-2.20.1-1.lvn8
pulseaudio-0.9.7-0.17.svn20071017.fc8

How reproducible:
Always

Steps to Reproduce:
1. Install F8
2. Install livna repository rpm for F8 from rpm.livna.org
3. rpm -e totem
4. yum -y install totem-xine
5. Try to play video
  
Actual results:
Totem crashes with the error message above.

Expected results:
Movie should play.

Additional info:
Comment 1 Jason 2007-11-19 22:45:32 EST
I just took several steps as part of troubleshooting steps recommended from 
this forum: http://forums.fedoraforum.org/showthread.php?t=171083

The parts involved were as follows: 
-------------------------------------------------------------------
edit /etc/security/console.perms.d/50-whatever it's called, and add
<sound>=/dev/dsp* /dev/snd/*
Then, at the bottom add 
<console> 0666 <sound> 0600 root
-------------------------------------------------------------------
remove alsa-plugins-pulseaudio.
-------------------------------------------------------------------
Problem was in my out of date /etc/asound.conf...
...should be:

pcm.!default {
    type pulse
}
ctl.!default {
    type pulse
}
-------------------------------------------------------------------

I made all of these changes, rebooted, and sound once again started working 
with totem-xine. None of this was required on my x86 systems, so I am not sure 
what the difference is, but there's something different.
Comment 2 serge lacroute 2007-12-06 16:44:09 EST
the answer to the bug doesn't seem to work. The file
/etc/security/console.perms.d/50-whatever doesn't exist.
Comment 3 Jason 2007-12-09 19:08:16 EST
The alsa plugin for pulseaudio is broken on the PS3 (looks like upstream bug
with "24 bit only" sound cards based on output from aplay when attempting to
play audio.


Proper configuration of pulseaudio on the PS3 can work around this issue and
sound will work as expected.

Note You need to log in before you can comment on or make changes to this bug.