Bug 37871 - Make fails in aic7xxxx and ncp/spx
Make fails in aic7xxxx and ncp/spx
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-26 12:21 EDT by Need Real Name
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-06 07:53:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-04-26 12:21:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows NT; DigExt)


	I'm running into the following: I wrote a test execution agent on  
RH 6.2 (I mention this to explain why such an heterogenuos mix) I have to 
be able to mount NetWare volumes from RH 6.2, also I need to publish some 
RH 6.2 filesystems using NFS so Solaris and several Linux flavors can see 
them. The box that is running RH 6.2 has SCSI hard drives. As you may 
know, RH 6.2 kernel is pre 2-2.18 (which is the minimum required by NFS to 
act as a NFS server to OS diferent from Linux) 

	So, I downloaded from kernel.org 2-2.18, 2-3.X and 2-4.X. I 
haven't touched that source at all. I'm following the How-To steps. I 
tried to recompile the kernel (2-2.18) with SCSI (aic7xxxx), NFS suport 
and IPX suport. First, I attempted to add them directly into the kernel. 
When I reached "nohup make bzImage &" the make failed. I'm assuming at the 
end, because make had already gone through net and scsi.

Then I decided to have these two as modules (scsi, spx) Compilation and 
making succeeds, but this kernel doesn't boot. It fails with : kernel 
panic: vfs can't mount /root" or something really similar (I generated the 
initrd... file).

Then I decided to install 7.0 with the same results as above.




Reproducible: Always
Steps to Reproduce:
Read description	

Actual Results:  Read description

Expected Results:  Successful make and loading of the kernel

I used xconfig.
Comment 1 Need Real Name 2001-04-26 12:26:31 EDT
I forgot to add that aic7xxxx and ncp/spx modules fail with "memcpy: symbol not 
found"
Comment 2 Arjan van de Ven 2001-04-26 12:28:48 EDT
You might have forgotten to run the lilo program
or even to change the configuration of it.
Having said that, we (Red Hat) have made a 2.2.19 kernel upgrade available
for Red Hat Linux 6.2

Look in the "updates" directory of your local Red Hat Linux ftp mirror...

see http://www.redhat.com/support/errata/RHSA-2001-047.html for more details.
Comment 3 Need Real Name 2001-04-26 12:31:52 EDT
I ran lilo. Otherwise, I wouldn't be able to load this new kernel. I'll try 
this new kernel, though

Note You need to log in before you can comment on or make changes to this bug.