Bug 37872 - enable PASSFILE option
Summary: enable PASSFILE option
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: pine   
(Show other bugs)
Version: phoebe
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-26 17:20 UTC by Rex Dieter
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-21 01:57:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pine-4.33-passfile.patch (667 bytes, patch)
2001-04-26 17:22 UTC, Rex Dieter
no flags Details | Diff

Description Rex Dieter 2001-04-26 17:20:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)


Feature request: please enable the PASSFILE option to enable the saving of 
passwords between pine sessions.  Most other e-mail clients have this 
capability, and it would be nice if pine on redhat did too.  

Here's a suggested patch to add to pine's specfile that enabled this 
feature:

--- pine4.33/pine/osdep/os-lnx.h_orig	Tue Apr 10 08:58:30 2001
+++ pine4.33/pine/osdep/os-lnx.h	Tue Apr 10 09:07:40 2001
@@ -225,6 +225,12 @@
 /*--------- Program employed by users to change their password ---------*/
 #define	PASSWD_PROG	"/usr/bin/passwd"
 
+/*----------------------------------------------------------------------
+    File name used to store the user's server/id/password triple between
+ session.  It is rooted in the same directory as the PINERC.
+ ----*/
+#define PASSFILE        ".pine.pwd"
+
 
 /*-------------- A couple constants used to size arrays ----------------*/
 #include <sys/param.h>          /* Get it from param.h if available */

Comment 1 Rex Dieter 2001-04-26 17:22:26 UTC
Created attachment 16525 [details]
pine-4.33-passfile.patch

Comment 2 Mike A. Harris 2001-04-26 19:45:29 UTC
This has security implications that will have to be looked at.  I will
look into it and take it into consideration for some future release of
Red Hat Linux.

Comment 3 Mike A. Harris 2001-07-31 09:41:30 UTC
I've looked into this and due to the history of bad security with
UW PINE and UW IMAP, I do not want to enable this option.  Once it
is enabled, then it must be supported, and I am not comfortable
supporting such an option at this time.

Comment 4 Rex Dieter 2001-07-31 13:53:59 UTC
While it's completely up to you, I am a little disappointed in your decision. 
On the other hand, the pine docs DO say that this option is not enabled by
default, precisely for the reason you express: possible security consequences.

Despite that, I requested this feature because it is easily the BIGGEST
complaint I receive from pine users: Why do I have to retype my password every
time I run it?  Understand, too, that password saving is not enabled by default,
even with my patch:  the file ~/.pine.pwd (or whatever you want to call it) must
exist first.


Comment 5 Mike A. Harris 2003-01-21 01:57:19 UTC
This bug was just set to REOPENED status, and with no comment added.
Since rationale for this being disabled by default has not changed,
the resolution for this bug hasn't changed either.

Closing enhancement request once again as WONTFIX, due to lack of
a WONTENHANCE resolution in bugzilla.


Note You need to log in before you can comment on or make changes to this bug.