Bug 378721 - Can't export to Picasa Web
Can't export to Picasa Web
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: f-spot (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Nigel Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-12 15:53 EST by gareth foster
Modified: 2008-07-30 16:05 EDT (History)
0 users

See Also:
Fixed In Version: 0.4.3.1-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-30 16:05:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description gareth foster 2007-11-12 15:53:36 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.1.8) Gecko/20071030 Fedora/2.0.0.8-2.fc8 Firefox/2.0.0.8

Description of problem:
f-spot can't seem to export to picasa web anymore
 http://pastebin.com/d1ddb08c8
 it keeps rejecting my keyring password, so i have to press deny eventually and then that lot appears
 the key ring is in actual fact already unlocked so this is a bit of a mess

An unhandled exception was thrown: Access denied

  at Gnome.Keyring.Ring.SendRequest (System.IO.MemoryStream stream) [0x00000] 
  at Gnome.Keyring.Ring.CreateItem (System.String keyring, ItemType type, System.String displayName, System.Collections.Hashtable attributes, System.String secret, Boolean updateIfExists) [0x00000] 
  at FSpot.GoogleAccountManager.WriteAccounts () [0x00000] 
  at FSpot.GoogleAccountManager.MarkChanged (Boolean write, FSpot.GoogleAccount changed_account) [0x00000] 
  at FSpot.GoogleAccountManager.AddAccount (FSpot.GoogleAccount account, Boolean write) [0x00000] 
  at FSpot.GoogleAccountManager.AddAccount (FSpot.GoogleAccount account) [0x00000] 
  at FSpot.GoogleAccountDialog.HandleAddResponse (System.Object sender, Gtk.ResponseArgs args) [0x00000] 
  at Gtk.Dialog.ResponseSignalCallback (IntPtr arg0, Int32 arg1, IntPtr gch) [0x00000] 
  at (wrapper native-to-managed) Gtk.Dialog:ResponseSignalCallback (intptr,int,intptr)
  at <0x00000> <unknown method>
  at (wrapper managed-to-native) Gtk.Application:gtk_main ()
  at Gtk.Application.Run () [0x00000] 
  at Gnome.Program.Run () [0x00000] 
  at FSpot.Driver.Main (System.String[] args) [0x00000] 
.NET Version: 2.0.50727.42

Assembly Version Information:

gnome-keyring-sharp (0.1.0.0)
Mono.Google (0.1.0.0)
Mono.Addins.Gui (0.2.0.0)
pango-sharp (2.10.0.0)
SemWeb (0.7.1.0)
glade-sharp (2.10.0.0)
gtkhtml-sharp (2.16.0.0)
System.Transactions (2.0.0.0)
System.Data (2.0.0.0)
Mono.Data.SqliteClient (2.0.0.0)
System.Configuration (2.0.0.0)
System.Xml (2.0.0.0)
gconf-sharp (2.16.0.0)
gdk-sharp (2.10.0.0)
gnome-vfs-sharp (2.16.0.0)
Mono.Addins (0.2.0.0)
NDesk.DBus.GLib (0.3.0.0)
NDesk.DBus (1.0.0.0)
System (2.0.0.0)
Mono.Posix (2.0.0.0)
atk-sharp (2.10.0.0)
gtk-sharp (2.10.0.0)
Mono.Addins.Setup (0.2.0.0)
glib-sharp (2.10.0.0)
gnome-sharp (2.16.0.0)
f-spot (0.4.0.0)
Mono.GetOptions (2.0.0.0)
mscorlib (2.0.0.0)

Platform Information: Linux 2.6.23.1-42.fc8 i686 i386 GNU/Linux

Distribution Information:

[/etc/redhat-release]
Fedora release 8 (Werewolf)

[/etc/system-release]
Fedora release 8 (Werewolf)

[/etc/fedora-release]
Fedora release 8 (Werewolf)

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. sign up to picasa
2. try to export to it
3.

Actual Results:
see main text

Expected Results:
it works

Additional info:
Comment 1 gareth foster 2008-05-24 08:16:34 EDT
Randomly fixed on F9 ... or is it because I used @googlemail.com on the end of
the "username" field?
Comment 2 Nigel Jones 2008-07-15 06:27:04 EDT
I've built 0.4.3.1 as a potential update for Fedora 8, while it's not in the
updates-testing repository yet, you can grab the RPM from
http://kojipkgs.fedoraproject.org/packages/f-spot/0.4.3.1/1.fc8/ would you
please be able to check if you can still reproduce the bug?
Comment 3 gareth foster 2008-07-15 14:26:56 EDT
I'm on F9 now, it works.
Comment 4 Nigel Jones 2008-07-25 01:23:48 EDT
(In reply to comment #3)
> I'm on F9 now, it works.

Thanks, the update is marked as stable for F8, I'll let bodhi close this one so 
it feels like it's doing something :)
Comment 5 Fedora Update System 2008-07-30 16:05:11 EDT
f-spot-0.4.3.1-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.