Bug 378801 - Please consider adding freeradius-python subpackage
Please consider adding freeradius-python subpackage
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: freeradius (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: John Dennis
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-12 16:23 EST by Paul P Komkoff Jr
Modified: 2008-04-17 14:23 EDT (History)
1 user (show)

See Also:
Fixed In Version: freeradius-2.0.3-1.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-17 14:23:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to enable freeradius-python subpackage (1.37 KB, patch)
2007-11-12 16:23 EST, Paul P Komkoff Jr
no flags Details | Diff

  None (edit)
Description Paul P Komkoff Jr 2007-11-12 16:23:27 EST
Please consider adding freeradius-python subpackage.
The attached patch will enable building of rpm_python plugin and creates
separate package for it.
The module is very useful when writing custom accounting and auth systems.

I hope I will be able to change it's "experimental" status soon. The module
itself is working on my systems for couple of years now.
Comment 1 Paul P Komkoff Jr 2007-11-12 16:23:27 EST
Created attachment 255801 [details]
Patch to enable freeradius-python subpackage
Comment 2 John Dennis 2007-11-12 18:02:02 EST
I agree, python support would be quite nice, however I'm concerned about
stability, robustness, and my limited time to field bug reports on this module.
If we ship it I have to support it.

A quick search for stability issues came up with this thread:

http://www.nabble.com/rlm_python-t3125545.html

Those comments were from January. I don't have time at the moment to research
what might have changed since then. If you would like to do some of the leg work
on that it would help, including finding whatever patches are being talked about
and making sure they've been committed to the upstream CVS. The fact it
currently works for you is not sufficient evidence it's ready to be shipped in
production code.

If you can help nail those issues down it would help a great deal. Fedora has a
strong bias toward python and it would be appropriate to ship this module, but
only if it's ready for prime time.
Comment 3 Paul P Komkoff Jr 2007-11-13 11:52:11 EST
Heh... If you follow the links in that thread you will see that people mention
that "patched" module works for them, and links are pointing at my messages :)

That said, my version of rlm_python was submitted to upstream this year (between
1.1.5 and 1.1.6 I think). What you have right now in upstream source is no
longer leaks memory or segfaults.
Comment 4 Paul P Komkoff Jr 2007-11-13 12:00:37 EST
You are right and when people will start using this module new bugs could be
exposed. However I don't think they'll be serious... I can deal with them.
Comment 5 Paul P Komkoff Jr 2007-12-06 12:13:56 EST
Hi!

Any news?
Comment 6 Paul P Komkoff Jr 2008-01-19 10:49:52 EST
rlm_python is marked stable in freeradius 2.0.0, so as long as you will not
explicitly mark it as unstable, it will either go into the main package or
require a subpackage.

Note You need to log in before you can comment on or make changes to this bug.