Bug 378821 - gdm display definition of "inactive" does not work as documented
gdm display definition of "inactive" does not work as documented
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-12 16:28 EST by John Tapparo
Modified: 2009-01-09 00:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 00:11:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Tapparo 2007-11-12 16:28:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.12) Gecko/20070530 Fedora/1.5.0.12-1.fc5 Firefox/1.5.0.12

Description of problem:
According to the gdm configuration documentation:
http://www.gnome.org/projects/gdm/docs/2.20/configuration.html#attacheddisplayconfig

"The first word of the value can also be set to the string "inactive" to indicate that this DISPLAY should not be managed. This can be used in the GDM Custom Configuration File to turn off a DISPLAY that is defined in the GDM System Defaults Configuration File."


When I put the line "0=inactive" in my /etc/gdm/custom.conf file, gdm is launched on the console.  I get the following log message in /var/log/messages:
Nov 12 16:12:13 hostname gdm-binary[6946]: WARNING: Server name 'inactive' not found; using standard server

Version-Release number of selected component (if applicable):
gdm-2.20.1-5.fc8

How reproducible:
Always


Steps to Reproduce:
1.  Modify the /etc/gdm/custom.conf file and add a line "0=inactive" to the "[servers]" section.
2.  Restart gdm (I have tried reboot as well as "init 3" then "init 5")

Actual Results:
The following warning is logged /var/log/messages and a gdmgreeter is started on the console.

WARNING: Server name 'inactive' not found; using standard server

Expected Results:
No X should be started on the console of the machine.

Additional info:
I have this configuration because the machine is remote and I don't need a graphical interface on the machine, I just want a text console.  However, I have gdm running so that I can point a remote display to it (chooser on another Linux machine).

As far as I recall, this worked properly in Fedora 7.

I performed a "strings /usr/sbin/gdm-binary | grep -i inactive" just to make sure that I had the case correct, but the only string reported was actually "inactive".   I have not surfed the source code yet.

I have seen this both on the i386 and x86_64 package.

I would like to see this work.  Perhaps there is additional information needed in the documentation.

I'm not sure if this should be medium or low severity.  I would like to see it fixed.  I don't have a workaround.  Other than starting an unnecessary X display on the server, there does not seem to be a huge impact.
Comment 1 Göran Uddeborg 2007-12-28 15:12:27 EST
I can confirm that it did work previously.  It just stopped working here on an
upgrade to F8 gdm.
Comment 2 John Tapparo 2008-05-11 13:15:40 EDT
This seems to have been fixed.  I noticed that gdm was in my yum update today,
so I checked, and my :0 display is no longer actve (as configured).  The package
that was installed is gdm-2.20.5-1.fc8.
Comment 3 Bug Zapper 2008-11-26 03:22:32 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Bug Zapper 2009-01-09 00:11:10 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.