Bug 378871 - Wireshark doesn't understand IPv6 addrs in /etc/resolv.conf
Wireshark doesn't understand IPv6 addrs in /etc/resolv.conf
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: wireshark (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Radek Vokal
Fedora Extras Quality Assurance
http://bugs.wireshark.org/bugzilla/sh...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-12 16:54 EST by Valdis Kletnieks
Modified: 2007-12-21 04:58 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-21 04:58:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Valdis Kletnieks 2007-11-12 16:54:52 EST
Description of problem:
When launching Wireshark on my laptop, it tosses 2 error messages:
 adns: /etc/resolv.conf:3: invalid nameserver address
`2001:468:c80:6101:213:72ff:fefc:d5cc'
adns: /etc/resolv.conf:5: invalid nameserver address
`2001:468:c80:2101:213:72ff:fefc:e1ff'

(Yes, there *are* BIND nameservers listening at those addresses, and they work
just fine for pretty much everything that uses the resolver in glibc).


Version-Release number of selected component (if applicable):
wireshark-0.99.6-3.fc8

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
Wireshark should use IPv6 DNS servers if they are configured.  Failing that, it
should at least be able to *parse* the line, realize it's IPv6, and fallback to
to the 3 valid IPv4 nameservers also listed.


Additional info:
Comment 1 Radek Vokal 2007-11-21 11:35:36 EST
Still reproducible with 0.99.7 - I filed an upstream bug and will dig into this
issue .. 
Comment 2 Radek Vokal 2007-11-21 14:04:23 EST
Ok, the problem seems to be adns .. it lacks the IPv6 support. I can either
disable adns support (which was enabled recently and I haven't realized this
issue) or wait till it gets fixed on adns side .. 
Comment 3 Radek Vokal 2007-12-21 04:58:27 EST
New release of adns was just added to rawhide and the IPv6 support is still not
there. So I'm removing adns support from wireshark (it can be easily recompiled
with the support, see spec file) and closing this bug as WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.