Bug 37891 - strange rpm installation location choices
strange rpm installation location choices
Status: CLOSED RAWHIDE
Product: Red Hat Powertools
Classification: Retired
Component: mpich (Show other bugs)
7.1
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
n/a
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-26 14:08 EDT by Mike Rubel
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-30 12:21:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Rubel 2001-04-26 14:08:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i686)


All relevant files are stored under /usr/lib/mpich/, which has its own
bin, doc, lib, include, and so on.  Why installed in such an odd way?
Install should work like GNU stow; libs in /usr/lib, man pages in
/usr/share/man, bins in /usr/bin, includes in /usr/include, and so on.

Reproducible: Always
Steps to Reproduce:
1. cd /mnt/cdrom/RedHat/RPMS/; #7.1 powertools cd-rom
2. rpm -qlp mpich-1.2.0-12.i386.rpm
	

Actual Results:  files to be located in /usr/lib/mpich/ and
/usr/share/doc/mpich-1.2.0/

Expected Results:  files to be located in more conventional places,
/usr/lib, /usr/share/doc/, /usr/share/man, /usr/include, /usr/bin, etc.

With mpich installed as the rpm package specifies, nothing (manuals, bins,
and so on) ends up being visible to an end user with normal $PATH choices. 
The user would need to be told (by sysadmin) that the package has been
installed, and where to find it.
Comment 1 Trond Eivind Glomsrxd 2001-04-27 10:22:16 EDT
It's installed this way because the package doesn't honor what it's told to with
configure.

I'll take a shot at fixing it when I upgrade the package.


Comment 2 Trond Eivind Glomsrxd 2001-04-30 12:20:55 EDT
Their build system is still rather "interesting" (AKA horrible), and really,
really wants the files there.
Comment 3 Trond Eivind Glomsrxd 2001-05-01 10:17:05 EDT
mpich 1.2.1-1 moves the files to saner locations.

Note You need to log in before you can comment on or make changes to this bug.