Bug 37892 - Japanese text output causes hangs when using Xinerama
Japanese text output causes hangs when using Xinerama
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kterm (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nakai
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-26 14:34 EDT by Christian Bauer
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-18 01:47:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Bauer 2001-04-26 14:34:34 EDT
Programs that output Japanese text (kterm, galeon/Netscape on Japanese web
pages, kinput2 kanji selection, gjiten etc.) hang frequently on a
two-monitor Xinerama display. Easiest way to reproduce:

 1. Open kterm
 2. Enter "cat /lib/libc.so.6"

The output stops after a few lines and the kterm application is completely
unresponsive (it doesn't use any CPU time and can be killed with SIGINT
but doesn't refresh the window contents any more). xfs is not affected and
one can open another kterm and try again (it will hang at a different point
in the output, then).

When the X server has been started without the +xinerama option (but still
in dual-head mode), the problem doesn't appear. No other XFree86 settings
seem to have an effect. It appears to be Xinerama that causes it to fail.

System information:
  Duron 700MHz, Gigabyte GA-7IXE4 mainboard (AMD 750 chipset),
  Matrox G450 LE AGP graphics card using BETA 1.2.0 XFree86 drivers from
  www.matrox.com (also tried with RedHat-supplied mga_drv.o + Matrox
  mga_hal_drv.o)
Comment 1 Mike A. Harris 2001-05-07 12:12:13 EDT
This is not a supported configuration.  Xinerama is included but is not
something completely stable or tested.  The G450 driver is also new
that is only supported in singlehead configurations.  It may or may not
work dualheaded, but is only supported singlehead.  This may change in
a future release once XFree86 4.x matures.

The Matrox proprietary drivers are not supported.

This is most likely a bug in kterm however, and not in X, so I'm reassigning
to kterm, as I do not consider it a supported problem if it is a bug in
XFree86.
Comment 2 Christian Bauer 2001-05-08 10:18:00 EDT
As mentioned in the original report, the bug affects all programs I have tested
that output Japanese text (galeon, gjiten etc.), not just kterm. kterm was only
given as an example that was easy to reproduce. So I don't understand why this
has now been reassigned as a kterm bug. It definitely looks like an X11 font
handling or rendering problem.
Comment 3 Christian Bauer 2001-07-24 14:04:58 EDT
Upgrading to XFree86-4.1.0-0.8.6 from rawhide fixed this problem.
Comment 4 Akira TAGOH 2003-04-18 01:47:20 EDT
I'm closing this now.

Note You need to log in before you can comment on or make changes to this bug.