Bug 378991 - virt-manager Unable to complete install: NoneType
virt-manager Unable to complete install: NoneType
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
8
i386 Linux
low Severity high
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-12 17:38 EST by Michael Ploujnikov
Modified: 2008-01-22 10:52 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.5.3-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-22 10:52:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Ploujnikov 2007-11-12 17:38:00 EST
Description of problem:
At the end of the virtual machine creation process I get an error message box
and that prevents me from finishing the creation of a virtual machine.

Version-Release number of selected component (if applicable):
virt-manager 0.5.2

How reproducible:
always

Steps to Reproduce:
1. run virt-manager (unprivileged)
2. connect to the localhost machine
3. right click on the localhost machine and select "New"
4. click forward
5. name the machine "fedora7test"
6. click forward (accept fully virtualized i686 arch with kernel/hardware
acceleration)
7. select an iso for booting
8. select OS type as "Linux"
9. select OS Variant as "Fedora 7"
10. click "Forward"
11. set hdd image path to "/home/plouj/vm/fedora7test.img"
12. click "Forward" twice (accepting 500MB virtual machine RAM and 1 VCPU)
13. click "Finish"
14. wait for virtual disk creation to finish


Actual results:
Message box with the following pops up:

Unable to complete install '<type 'exceptions.AttributeError'> 'NoneType' object
has no attribute 'setup'
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/create.py", line 616, in do_install
    dom = guest.start_install(False, meter = meter)
  File "/usr/lib/python2.5/site-packages/virtinst/Guest.py", line 724, in
start_install
    return self._do_install(consolecb, meter)
  File "/usr/lib/python2.5/site-packages/virtinst/Guest.py", line 736, in
_do_install
    self._create_devices(meter)
  File "/usr/lib/python2.5/site-packages/virtinst/Guest.py", line 644, in
_create_devices
    nic.setup(self.conn)
AttributeError: 'NoneType' object has no attribute 'setup'
'

Expected results:
Virtual machine is successfully created without any errors.

Additional info:
Comment 1 Stewart Hardie 2007-11-23 23:16:57 EST
I got a similar result in F8. This was trying to create a virtual machine using
qemu and kvm running Windows XP. I tried it running Virtual Machine Manager as
unprevileged when starting it. Trying again, entering root password on VM
Manager startup, allowed successful creation of the virtual machine.
Comment 2 Stewart Hardie 2007-11-23 23:19:21 EST
In addition, running the root password provided an extra config screen when
creating the VM. This was to do with with the type of network (virtualised etc)
to be connected to the VM.
Comment 3 Cole Robinson 2008-01-10 13:45:51 EST
I just applied a fix for this upstream.

http://hg.et.redhat.com/virt/applications/virt-manager--devel?cs=f11ccb3e5264

I will close this bug when a new release is cut and pushed to F8. Thanks for bug
report!
Comment 4 Fedora Update System 2008-01-11 17:23:34 EST
virt-manager-0.5.3-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update virt-manager'
Comment 5 Soren Hansen 2008-01-14 06:55:08 EST
While the problem as described has gone away, the patch only fixes half of the
problem. The other half of the problem is that no NIC's get defined for the
guests. This is due to the fact that vmmCreate._net gets populated in
vmmCreate.validate(PAGE_NETWORK), but as that page is never shown to
unprivileged users, the network never gets configured.
Comment 6 Cole Robinson 2008-01-15 10:02:19 EST
Hmm, I'm not too familiar with how user mode networking is done: I was under the
impression the page was deliberately skipped in the install because a regular
user couldn't use any of the presented options. Let's use this bug to track the
install failure issue, and I'll open a bug for the lack-of-networking issue.
Comment 7 Cole Robinson 2008-01-15 12:10:42 EST
bz #378991 : add usermode networking support to virt-manager
Comment 8 Cole Robinson 2008-01-15 12:11:47 EST
gah... my brain failed. bug is  bz 428852 :

https://bugzilla.redhat.com/show_bug.cgi?id=428852
Comment 9 Fedora Update System 2008-01-22 10:52:15 EST
virt-manager-0.5.3-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.