This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 379321 - missing drivers not installed by applet
missing drivers not installed by applet
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F8Target
  Show dependency treegraph
 
Reported: 2007-11-12 23:20 EST by Otto Rey
Modified: 2008-01-29 00:17 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.7.74.10-2.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-29 00:15:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Otto Rey 2007-11-12 23:20:31 EST
Description of problem:
I own an HP Photosmart C4180. Fedora detect this printer without problems. But
when i want to print, nothing happen.

Version-Release number of selected component (if applicable):
system-config-printer-0.7.74.4-3.fc8

How reproducible:
Always

Steps to Reproduce:
1. Install Fedora (fresh install)
2. Launch system-config-printer
3. See HP printer detected.
4. Start printing test page
  
Actual results:
Nothing happen

Expected results:
Test page get printed

Additional info:
Installing hplip package solve the problem, but nobody tell me
Comment 1 Eric Ziegenhorn 2007-11-30 10:57:20 EST
The same thing happens to me with my HP Photosmart C3180 -- it is quite
mysterious and I got very lucky stumbling upon this bug.
Comment 2 Tim Waugh 2007-11-30 11:18:17 EST
What probably ought to happen is that system-config-printer-applet, which is
responsible for displaying the "new printer" notification bubble, should perform
the same checks as system-config-printer to see if the necessary drivers are
installed, and offer to install them if need be.
Comment 3 Eric Ziegenhorn 2007-11-30 11:30:08 EST
That sounds reasonable to me.  Thanks for creating this bug in the first place.
 I can verify that installing hplip made my printer work as well.
Comment 4 Otto Rey 2008-01-13 13:02:38 EST
Yes! Comment #2 sounds as the right path, because when adding a HP Network
Printer in system-config-printer, Fedora ask me to install hplip package to work. 
Comment 5 Tim Waugh 2008-01-16 11:31:53 EST
Fixed upstream.
Comment 6 Fedora Update System 2008-01-22 10:33:52 EST
system-config-printer-0.7.74.9-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'
Comment 7 Fedora Update System 2008-01-22 10:46:38 EST
system-config-printer-0.7.74.9-2.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'
Comment 8 Tim Waugh 2008-01-23 10:47:26 EST
Not sure this is working right in 0.7.74.9-2.fc8.  I'm not getting a
notification bubble.
Comment 9 Fedora Update System 2008-01-27 02:12:11 EST
system-config-printer-0.7.74.10-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'.  You can provide feedback for this update here: http://admin.fedoraproject.org/F8/FEDORA-2007-3416
Comment 10 Fedora Update System 2008-01-29 00:15:38 EST
system-config-printer-0.7.74.10-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2008-01-29 00:17:34 EST
system-config-printer-0.7.74.10-2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.