Bug 379351 - Qt4 font settings do not take effect
Qt4 font settings do not take effect
Status: CLOSED DUPLICATE of bug 381311
Product: Fedora
Classification: Fedora
Component: qt4 (Show other bugs)
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-11-13 00:08 EST by Bohan
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-11-27 07:50:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
screenshot of qt4 font problem (86.42 KB, image/jpeg)
2007-11-13 00:08 EST, Bohan
no flags Details
Trolltech.conf (5.19 KB, text/plain)
2007-11-14 03:39 EST, Bohan
no flags Details
Screenshot of qt4 font problem 2 (210.45 KB, image/jpeg)
2007-11-14 16:03 EST, Bohan
no flags Details
Qt4 does _not_ use KDE's font settings (317.74 KB, image/png)
2007-11-15 21:20 EST, Patrick Nagel
no flags Details
New ugly default font in Qt4 after system update (541.94 KB, image/png)
2007-11-22 22:21 EST, Patrick Nagel
no flags Details

  None (edit)
Description Bohan 2007-11-13 00:08:58 EST
Description of problem:

In qtconfig-qt4, changing the font family has no effect, all fonts look the 
same. apps compiled against qt4 all have an 'ugly' 'console-like' font that 
can't be changed. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Launch qtconfig-qt4
2. Change fonts and click File->Save
3. Do the same in qtconfig (qt3 version), notice changes take effect 
4. Lauch Qt4 apps like qt4 designer and notice the same problem
Actual results:

Console-like, aliased font in all qt4 apps

Expected results:

Fonts change, so one can have consistent fonts between qt4 and KDE 3 apps

Additional info:

see screenshots
qt3 does not exhibit any of this weirdness
Comment 1 Bohan 2007-11-13 00:08:58 EST
Created attachment 256261 [details]
screenshot of qt4 font problem
Comment 2 Rex Dieter 2007-11-13 12:04:09 EST

Does your font changes make it to
Comment 3 Bohan 2007-11-14 03:39:32 EST
Created attachment 257791 [details]

mine shows a valid font
Comment 4 Rex Dieter 2007-11-14 07:43:45 EST
Right, it says:
font="DejaVu LGC Sans,10,-1,5,25,0,0,0,0,0"
Which seems to be what is being displayed in your screenshot, so I'm not sure
how this can be considered "font settings do not take effect". ??

You may want to consider using DejaVu.../Normal instead of DejaVu.../Light, though.
Comment 5 Bohan 2007-11-14 15:56:15 EST
The issue is I can change it to any font and its still the same.

For example I have it on PakTypeNaqsh - Normal (a really runny writing type) 
but the same window I attached still looks the same, even after saving and 

As a real world case: When compiling smplayer to use qt3 or kdelibs the fonts 
are good (either same as qtconfig or kde settings which can be changed) but 
compiling with qt4 results in unchangeable font family (its changes and 
persists, but all fonts look exactly the same). Font size and bold works as 
Comment 6 Rex Dieter 2007-11-14 16:01:37 EST
dunno what to tell you, as I said in comment #2, I cannot reproduce the issue
you're reporting and it worksforme.  ??
Comment 7 Bohan 2007-11-14 16:03:27 EST
Created attachment 258831 [details]
Screenshot of qt4 font problem 2

Screenshot showing PakType is working in kde but a qt4 (just to illustrate qt4
ignores the font settings).
Comment 8 Bohan 2007-11-14 16:09:22 EST
Actually you are right, it is a really small problem anyway, will do more 
research and find out what extra stuff needs to be configured before hand.

Thanks for your help.
Comment 9 Patrick Nagel 2007-11-15 00:22:33 EST
I have the same problem, and it's NOT a 'really small problem'. It's a serious
issue: Qt4 on Fedora 8 seems to be unable to use any font other than some
built-in fallback font or whatever this ugly font is.

The font family change in qtconfig-qt4 goes to ~/.config/Trolltech.conf
font=..., but it has no effect on any Qt4 application.

I hope this bug can be resolved soon, as it's very annoying for anybody who uses
Qt4 apps. I'm using a newly installed Fedora 8.

$ yum list *qt4*
Installed Packages
qt4.i386                                 4.3.2-1.fc8            installed
qt4-devel.i386                           4.3.2-1.fc8            installed
qt4-doc.i386                             4.3.2-1.fc8            installed
qt4-mysql.i386                           4.3.2-1.fc8            installed
qt4-x11.i386                             4.3.2-1.fc8            installed
Comment 10 Patrick Nagel 2007-11-15 01:22:47 EST
Note: I just found out, that in one place on my system, the font setting
actually works! Skype's buddy list window and the chat windows use the ugly
font, as all other Qt4 apps I use, but on that small notification window that
pops up when somebody sends a message to me, the font from
.config/Trolltech.conf is being used. This is weird...
Comment 11 Bohan 2007-11-15 02:12:13 EST
[bh@f8 ~]$ yum list installed *qt4*
Loading "basearchonly" plugin
Loading "protect-packages" plugin
Loading "skip-broken" plugin
Installed Packages
poppler-qt4.x86_64                       0.6-2.fc8              installed
poppler-qt4-devel.x86_64                 0.6-2.fc8              installed
qt4.x86_64                               4.3.2-1.fc8            installed
qt4-devel.x86_64                         4.3.2-1.fc8            installed
qt4-doc.x86_64                           4.3.2-1.fc8            installed
qt4-mysql.x86_64                         4.3.2-1.fc8            installed
qt4-odbc.x86_64                          4.3.2-1.fc8            installed
qt4-postgresql.x86_64                    4.3.2-1.fc8            installed
qt4-qsa.x86_64                           1.2.2-4.fc7            installed
qt4-qsa-devel.x86_64                     1.2.2-4.fc7            installed
qt4-sqlite.x86_64                        4.3.2-1.fc8            installed
qt4-theme-quarticurve.x86_64             0.0-0.6.1.beta5.fc8    installed
qt4-x11.x86_64                           4.3.2-1.fc8            installed
qwtplot3d-qt4.x86_64                     0.2.7-4.fc8            installed
qwtplot3d-qt4-devel.x86_64               0.2.7-4.fc8            installed
scim-bridge-qt4.x86_64                   0.4.13-4.fc8           installed

I am glad I'm not the only one with the problem.

Rex, If you know this is a configuration issue, just tell us approximately 
where to look and close the bug.
Comment 12 Rex Dieter 2007-11-15 07:46:09 EST
Which qt4-based apps don't work?  The one's *I* tested, that work for me
include: qtconfig, lyx.  Noticed now that designer instead used *kde*'s fonts
(Kcontrol->Appearance&Themes->Fonts), not what is set via qtconfig. 
Comment 13 Rex Dieter 2007-11-15 07:50:13 EST
Than, do you have comment?  Do you know under what circumstances qt4 uses it's
own font settings or when it inherits kde's?
Comment 14 Patrick Nagel 2007-11-15 21:20:33 EST
Created attachment 260661 [details]
Qt4 does _not_ use KDE's font settings
Comment 15 Dave Treweeke 2007-11-22 15:12:00 EST
I also have this issue.

As the screenshot in comment 7 clearly shows, the Font Family has been changed
to PakTypeNaqsh in the Qt Configuration window, yet the sample text shown in the
same window (which should reflect the selected font) stays unchanged.

I have noted in my testing that this problem only seems to occur (for me) with a
Point Size <14. Larger fonts render correctly.

As far as affected applications, Last.FM, Skype and the Qt Configuration util
all have these symptoms. Ugly fonts are used unless the point size is <14.

I'm unsure if this is going to be relevant or not, but I'm using a 22"
widescreen monitor at 1680x1050. qrdb-query output looks like this...

xrdb -query | grep Xft

Xft.antialias:  1
Xft.dpi:        85.000000
Xft.hinting:    1
Xft.hintstyle:  hintfull
Xft.rgba:       rgb
Comment 16 Dave Treweeke 2007-11-22 15:25:58 EST
Oops... previous comment should have read
"Ugly fonts are used if the point size is <14."

Apologies for the erroneous comment.
Comment 17 Rex Dieter 2007-11-22 15:38:39 EST
For the record, I (still) can't reproduce (i'm only checking against
qtconfig-qt4's preview text atm), and am pretty much baffled.

$xrdb -query | grep Xft
Xft.antialias:  1
Xft.dpi:        96
Xft.hinting:    1
Xft.hintstyle:  hintmedium
Xft.rgba:       rgb

What X/video hardware/drivers are (any of) you using? 

X intel_drv
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS,
943/940GML Express Integrated Graphics Controller (rev 03)
Comment 18 Rex Dieter 2007-11-22 17:24:35 EST
Since we're mostly stumped here, for those seeing this, please take this issue
for discussion to the qt/trolltech mailing list.  Maybe the smart, kind folks
there can help shed some light on this:
Comment 19 Patrick Nagel 2007-11-22 22:21:50 EST
Created attachment 267321 [details]
New ugly default font in Qt4 after system update

Interesting. Just now I applied the following updates (coming in through yum):

Nov 23 11:08:22 Updated: system-config-firewall-tui - 1.0.11-1.fc8.noarch
Nov 23 11:08:23 Updated: smolt - 1.0-1.fc8.noarch
Nov 23 11:08:24 Updated: smolt-firstboot - 1.0-1.fc8.noarch
Nov 23 11:08:28 Updated: system-config-firewall - 1.0.11-1.fc8.noarch
Nov 23 11:08:33 Updated: wqy-bitmap-fonts - 0.9.9-1.fc8.noarch
Nov 23 11:08:34 Updated: libao - 0.8.8-2.fc8.i386
Nov 23 11:08:37 Updated: setroubleshoot-plugins - 1.10.4-1.fc8.noarch
Nov 23 11:08:38 Updated: bind-libs - 32:9.5.0-18.a7.fc8.i386
Nov 23 11:08:39 Updated: pilot-link - 2:0.12.2-7.fc8.i386
Nov 23 11:08:40 Updated: bind-utils - 32:9.5.0-18.a7.fc8.i386

And now the font in all Qt4 applications changed from that one that can be seen
in screenshot in comment #14 to a monotype fixed-width font with serifs (see
attached screenshot). Otherwise nothing changed - the bug is still there, font
is unchangeable.

Replying to #18: Probably a good idea. I guess it would be even more helpful,
if the Qt4 packager for Fedora contacted the Trolltech guys...
Comment 20 Rex Dieter 2007-11-22 22:58:33 EST
Not if said packager (me) can't reproduce it.  :(  The conversation really needs
to be initiated by someone who is actually experiencing the problem.   I promise
to follow and aid in any upstream ml conversations. 
Comment 21 Dave Treweeke 2007-11-23 08:54:19 EST
I've posted this issue onto the trolltech list that was mentioned in comment #18
although there've been no reponses to date.
Comment 22 Patrick Nagel 2007-11-27 00:05:21 EST
The issue has been resolved by today's batch of updates:

Nov 27 11:18:04 Updated: wine-core - 0.9.49-1.fc8.i386
Nov 27 11:18:07 Updated: samba-common - 3.0.27a-0.fc8.i386
Nov 27 11:18:07 Updated: gstreamer-tools - 0.10.15-1.fc8.i386
Nov 27 11:18:08 Updated: pkgconfig - 1:0.22-4.fc8.i386
Nov 27 11:18:08 Updated: info - 4.11-2.fc8.i386
Nov 27 11:18:09 Updated: texinfo - 4.11-2.fc8.i386
Nov 27 11:18:11 Updated: gstreamer - 0.10.15-1.fc8.i386
Nov 27 11:18:11 Updated: wine-twain - 0.9.49-1.fc8.i386
Nov 27 11:18:11 Updated: wine-capi - 0.9.49-1.fc8.i386
Nov 27 11:18:12 Updated: wine-ldap - 0.9.49-1.fc8.i386
Nov 27 11:18:12 Updated: wine-cms - 0.9.49-1.fc8.i386
Nov 27 11:18:12 Updated: wine-esd - 0.9.49-1.fc8.i386
Nov 27 11:18:13 Updated: wine-tools - 0.9.49-1.fc8.i386
Nov 27 11:18:13 Updated: wine-jack - 0.9.49-1.fc8.i386
Nov 27 11:18:13 Updated: wine-nas - 0.9.49-1.fc8.i386
Nov 27 11:18:16 Updated: iptables - 1.3.8-6.fc8.i386
Nov 27 11:18:17 Updated: net-snmp-libs - 1:5.4.1-5.fc8.i386
Nov 27 11:18:17 Installed: gtk-nodoka-engine - 0.6-5.fc8.i386
Nov 27 11:18:19 Updated: gail - 1.20.1-2.fc8.i386
Nov 27 11:18:20 Updated: iptables-ipv6 - 1.3.8-6.fc8.i386
Nov 27 11:18:20 Updated: texinfo-tex - 4.11-2.fc8.i386
Nov 27 11:18:22 Updated: samba - 3.0.27a-0.fc8.i386
Nov 27 11:18:23 Updated: samba-client - 3.0.27a-0.fc8.i386
Nov 27 11:18:24 Updated: xorg-x11-drv-ati - 6.7.196-1.fc8.i386
Nov 27 11:18:24 Updated: libsmbclient - 3.0.27a-0.fc8.i386
Nov 27 11:18:25 Updated: acpid - 1.0.6-4.fc8.i386
Nov 27 11:18:25 Installed: control-center-filesystem - 1:2.20.1-5.fc8.i386
Nov 27 11:18:26 Updated: smolt - 1.0-2.fc8.noarch
Nov 27 11:18:26 Updated: smolt-firstboot - 1.0-2.fc8.noarch
Nov 27 11:18:26 Updated: wine - 0.9.49-1.fc8.i386
Nov 27 11:18:27 Updated: python-iniparse - 0.2.2-2.fc8.noarch
Nov 27 11:18:31 Updated: wqy-bitmap-fonts - 0.9.9-2.fc8.noarch
Nov 27 11:18:31 Installed: nodoka-metacity-theme - 0.3.2-2.fc8.noarch
Nov 27 11:18:36 Updated: metacity - 2.20.1-1.fc8.i386

I observe that wqy-bitmap-fonts was in the batch of updates again, as it was on
November 23rd, when the behaviour of Qt regarding fonts changed for the first time.
Comment 23 Rex Dieter 2007-11-27 07:50:26 EST
Ha!  It's a wqy-bitmap-fonts bug apparently.  Nice investigative work Patrick.

*** This bug has been marked as a duplicate of 381311 ***

Note You need to log in before you can comment on or make changes to this bug.