Bug 37941 - AIC-76xxx and AIC-76xxx_mod and Adaptec 7892P (rev 02)
AIC-76xxx and AIC-76xxx_mod and Adaptec 7892P (rev 02)
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-04-26 20:26 EDT by Johnray Fuller
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-09-17 10:56:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Johnray Fuller 2001-04-26 20:26:33 EDT
I tried to install 7.1 on a Netfinity 3500.

On boot I typed "noprobe" and selected the new experimental Adaptec driver.

I performed the installation on the box. This machine has no IDE drives and
two SCSI drives attached to the Adaptec 7892P (rev 02) controller.

I custom installed everything on half of /dev/sda1 (~5 gig).

On reboot from sda1, scsi0 loads the AIC7xxx_mod then a boot message for
scsi1 says it loaded aic7xxx. Then the following message is catted to the
screen infinately:

scsi0: ahc_intr_referenced scd not valid during SELTO scb (1,255)

I booted in rescue mode and tfound two separate entries in the modules.conf
for this one controller. I do not remember this behaviour from 7.0.

Here are the two entries.

alias scsi_hostadapter aic7xxx
alias scsi_hostadapter1 aic7xxx_mod

I tried screwing around with the modules by leaving only the first entry,
then by changing the module in the second entry to match one or the other
module and by making new initrd images, but nothing is working.

The box is in Meridian if you need to experiment :-)

Johnray out
Comment 1 Doug Ledford 2001-05-02 15:06:01 EDT
Those two modules should *never* be loaded at the same time.  Remove one of them
from the modules.conf file and make a new initrd, then open a bugzilla entry
against anaconda for putting both of them into the modules.conf file.
Comment 2 Johnray Fuller 2001-05-09 19:16:20 EDT
I reassigned the bug to Anaconda..

Thanks Doug...
Comment 3 Matt Wilson 2001-08-20 09:40:39 EDT
where is the machine?
Comment 4 Johnray Fuller 2001-08-20 16:21:50 EDT
The machine is at my desk in Meridian.

Buzz me if you need to look at it (I'm on the corporate phone-list).

Comment 5 Doug Ledford 2001-08-23 19:07:43 EDT
Changing assignment.  It's already assigned to anaconda, but it is still in my name.
Comment 6 Jeremy Katz 2001-09-05 17:48:08 EDT
Does this happen with Roswell2 or newer?
Comment 7 Brent Fox 2001-09-17 10:55:55 EDT
Any more info here?
Comment 8 Brent Fox 2001-09-27 14:51:10 EDT
Closing due to inactivity.  Please reopen if you have more information.

Note You need to log in before you can comment on or make changes to this bug.